1079. Total Sales of Supply Chain (25)

A supply chain is a network of retailers(零售商), distributors(经销商), and suppliers(供应商)-- everyone involved in moving a product from supplier to customer.

Starting from one root supplier, everyone on the chain buys products from one's supplier in a price P and sell or distribute them in a price that is r% higher than P. Only the retailers will face the customers.It is assumed that each member in the supply chain has exactly one supplier except the root supplier, and there is no supply cycle.

Now given a supply chain, you are supposed to tell the total sales from all the retailers.

Input Specification:

Each input file contains one test case. For each case, the first line contains three positive numbers: N (<=105), the total number of the members in the supply chain (and hence their ID's are numbered from 0 to N-1, and the root supplier's ID is 0); P, the unit price given by the root supplier; and r, the percentage rate of price increment for each distributor or retailer. Then N lines follow, each describes a distributor or retailer in the following format:

Ki ID[1] ID[2] ... ID[Ki]

where in the i-th line, Ki is the total number of distributors or retailers who receive products from supplier i, and is then followed by the ID's of these distributors or retailers. Kj being 0 means that the j-th member is a retailer, then instead the total amount of the product will be given after Kj. All the numbers in a line are separated by a space.

Output Specification:

For each test case, print in one line the total sales we can expect from all the retailers, accurate up to 1 decimal place. It is guaranteed that the number will not exceed 1010.

Sample Input:
10 1.80 1.00
3 2 3 5
1 9
1 4
1 7
0 7
2 6 1
1 8
0 9
0 4
0 3
Sample Output:
42.4

给出一个供应链,供应商只有一个,每经过一个经销商都会有固定的价格提升,求出从各个零售商那里得到的总收益。其实这个供应链就是一棵树,供应商是根节点,首先根据输入的节点信息构建一棵树,很容易找出叶节点(也就是零售商),它的val值设为零售商的需求量,其他节点的val值为-1。根据输入也很容易找到根节点。从根节点开始,用深度优先搜索,每一层更新倍率,直到叶节点(即val值不为-1的节点)算出从某一个零售商的得到的收益。最后算出总和即可。


代码:

#include <iostream>
#include <cstring>
#include <cstdlib>
#include <cstdio>
#include <vector>
using namespace std;

struct node
{
	int val;
	vector<int>next;
	node():val(-1){}
};
int n;
double p,r;
vector<node>chain;
double sum=0;

void dfs(int cur,double rate)
{
	if(chain[cur].val!=-1)
	{
		sum+=chain[cur].val*p*rate;
		return;
	}
	int n=chain[cur].next.size();
	for(int i=0;i<n;i++)
	{
		dfs(chain[cur].next[i],rate*(1+r/100));
	}
}

int main()
{	
	cin>>n>>p>>r;
	vector<bool>isroot(n,true);
	chain.resize(n);
	for(int i=0;i<n;i++)
	{
		int m;
		cin>>m;
		if(m==0)
		{
			int amount;
			cin>>amount;
			chain[i].val=amount;
		}
		else
		{
			for(int j=0;j<m;j++)
			{
				int next;
				cin>>next;
				isroot[next]=false;
				chain[i].next.push_back(next);
			}
		}
	}
	int root;
	for(int i=0;i<n;i++) 
	{
		if(isroot[i])
		{
			root=i;
			break;
		}
	}
	dfs(root,1);
	printf("%.1f",sum);
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值