1080. Graduate Admission (30)

It is said that in 2013, there were about 100 graduate schools ready to proceed over 40,000 applications in Zhejiang Province. It would help a lot if you could write a program to automate the admission procedure.

Each applicant will have to provide two grades: the national entrance exam grade GE, and the interview grade GI. The final grade of an applicant is (GE + GI) / 2. The admission rules are:

  • The applicants are ranked according to their final grades, and will be admitted one by one from the top of the rank list.
  • If there is a tied final grade, the applicants will be ranked according to their national entrance exam grade GE. If still tied, their ranks must be the same.
  • Each applicant may have K choices and the admission will be done according to his/her choices: if according to the rank list, it is one's turn to be admitted; and if the quota of one's most preferred shcool is not exceeded, then one will be admitted to this school, or one's other choices will be considered one by one in order. If one gets rejected by all of preferred schools, then this unfortunate applicant will be rejected.
  • If there is a tied rank, and if the corresponding applicants are applying to the same school, then that school must admit all the applicants with the same rank, even if its quota will be exceeded.

Input Specification:

Each input file contains one test case. Each case starts with a line containing three positive integers: N (<=40,000), the total number of applicants; M (<=100), the total number of graduate schools; and K (<=5), the number of choices an applicant may have.

In the next line, separated by a space, there are M positive integers. The i-th integer is the quota of the i-th graduate school respectively.

Then N lines follow, each contains 2+K integers separated by a space. The first 2 integers are the applicant's GE and GI, respectively. The next K integers represent the preferred schools. For the sake of simplicity, we assume that the schools are numbered from 0 to M-1, and the applicants are numbered from 0 to N-1.

Output Specification:

For each test case you should output the admission results for all the graduate schools. The results of each school must occupy a line, which contains the applicants' numbers that school admits. The numbers must be in increasing order and be separated by a space. There must be no extra space at the end of each line. If no applicant is admitted by a school, you must output an empty line correspondingly.

Sample Input:
11 6 3
2 1 2 2 2 3
100 100 0 1 2
60 60 2 3 5
100 90 0 3 4
90 100 1 2 0
90 90 5 1 3
80 90 1 0 2
80 80 0 1 2
80 80 0 1 2
80 70 1 3 2
70 80 1 2 3
100 100 0 2 4
Sample Output:
0 10
3
5 6 7
2 8

1 4

模拟学校录取学生的过程,输出每个学校录取了哪些学生。首先对学生进行排名,优先按照总分从大到小排,其次按照考试分数从大到小排,如果都一样则排名一样。由于排序后索引会打乱,所以一开始要储存好各个学生的id。排名后,根据排名的顺序,名次高的先选学校。对于某学生,如果当前学校还没满或许满了但他的总分和测试分和该学校的最后一名的总分和测试分一样,就进入该学校且轮到下个学生选。遍历完所有学生就得到各个学校的录取结果。


代码:

#include <iostream>
#include <cstring>
#include <cstdio>
#include <cstdlib>
#include <vector>
#include <algorithm>
using namespace std;

struct applicant
{
	int id;
	int ge;
	int gi;
	int total;
	int choice[10];
};

struct school
{
	int last_total;
	int last_ge;
	vector<int>apps;
};

bool cmp(const applicant& a1,const applicant& a2)
{
	if(a1.total!=a2.total) return a1.total>a2.total;
	else return a1.ge>a2.ge;
}

int main()
{
	int n,m,k;
	cin>>n>>m>>k;
	vector<applicant>apps(n);
	vector<int>quota(m);
	for(int i=0;i<m;i++)
	{
		cin>>quota[i];
	}
	for(int i=0;i<n;i++)
	{
		apps[i].id=i;
		cin>>apps[i].ge>>apps[i].gi;
		apps[i].total=apps[i].ge+apps[i].gi;
		for(int j=0;j<k;j++)
		{
			cin>>apps[i].choice[j];
		}
	}
	sort(apps.begin(),apps.end(),cmp);
	vector<school>schools(m);
	for(int i=0;i<n;i++)
	{
		for(int j=0;j<k;j++)
		{
			int c=apps[i].choice[j],s=schools[c].apps.size();
			if(s<quota[c])
			{
				schools[c].apps.push_back(apps[i].id);
				schools[c].last_total=apps[i].total;
				schools[c].last_ge=apps[i].ge;
				break;
			}
			else
			{
				if(apps[i].total==schools[c].last_total&&apps[i].ge==schools[c].last_ge)
				{
					schools[c].apps.push_back(apps[i].id);
					break;
				}
			}
		}
	}
	for(int i=0;i<m;i++)
	{
		sort(schools[i].apps.begin(),schools[i].apps.end());
		if(!schools[i].apps.empty()) cout<<schools[i].apps[0];
		for(int j=1;j<schools[i].apps.size();j++)
		{
			cout<<" "<<schools[i].apps[j];
		}
		cout<<endl;
	}
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值