素数个数的位数 | |||
| |||
description | |||
小明是一个聪明的孩子,对数论有着很浓烈的兴趣。他发现求1到正整数10n 之间有多少个素数是一个很难的问题,该问题的难以决定于n 值的大小。现在的问题是,告诉你n的值,让你帮助小明计算小于10n的素数的个数值共有多少位? | |||
input | |||
输入数据有若干组,每组数据包含1个整数n(1 < n < 1000000000),若遇到EOF则处理结束。 | |||
output | |||
对应每组数据,将小于10n 的素数的个数值的位数在一行内输出,格式见样本输出。同组数据的输出,其每个尾数之间空一格,行末没有空格。 | |||
sample_input | |||
3 7 | |||
sample_output | |||
3 6 |
思路:
素数定理: π(x)表示小于正实数x的素数的个数 ,有π(x)/(x/lnx)近似=1
推论:第n个素数Pn ~ nlnn
所以位数是:lg( 10^n / ln(10^n)) +1
//Accepted 872k 3ms C++ (g++ 3.4.3) 284
#include<cstdio>
#include<iostream>
#include<cstring>
#include<algorithm>
#include<cmath>
using namespace std;
int main()
{
double n;
while(~scanf("%lf",&n))
{
double c;
c=n-log10(n)-log10(log(10));
printf("%d\n",int(c)+1);
}
}