HDU 5285 wyh2000 and pupil(dfs或种类并查集)

wyh2000 and pupil

Time Limit: 3000/1500 MS (Java/Others)    Memory Limit: 131072/65536 K (Java/Others)
Total Submission(s): 755    Accepted Submission(s): 251


Problem Description
Young theoretical computer scientist wyh2000 is teaching his pupils.

Wyh2000 has n pupils.Id of them are from 1 to n .In order to increase the cohesion between pupils,wyh2000 decide to divide them into 2 groups.Each group has at least 1 pupil.

Now that some pupils don't know each other(if a doesn't know b ,then b doesn't know a ).Wyh2000 hopes that if two pupils are in the same group,then they know each other,and the pupils of the first group must be as much as possible.

Please help wyh2000 determine the pupils of first group and second group. If there is no solution, print "Poor wyh".
 

Input
In the first line, there is an integer T indicates the number of test cases.

For each case, the first line contains two integers n,m indicate the number of pupil and the number of pupils don't konw each other.

In the next m lines,each line contains 2 intergers x,y(x < y) ,indicates that x don't know y and y don't know x ,the pair (x,y) will only appear once.

T10,0n,m100000
 

Output
For each case, output the answer.
 

Sample Input
  
  
2 8 5 3 4 5 6 1 2 5 8 3 5 5 4 2 3 4 5 3 4 2 4
 

Sample Output
  
  
5 3 Poor wyh
 

大致题意:
n个点分成两组,m条边,每条边连接的两个点必须是在不同的两组,且第一组要尽量的大

思路:显然,dfs染色,不是二分图就无解。
还可以用种类并查集来做,把所有可能性合并,由对称性可知,只统计1~n是祖先时,看祖先的子节点中黑白节点是多少个就ok


//468MS 4036K 1981 B C++  
#include <iostream>
#include <cstring>
#include <cmath>
#include <queue>
#include <stack>
#include <list>
#include <map>
#include <set>
#include <sstream>
#include <string>
#include <vector>
#include <cstdio>
#include <ctime>
#include <bitset>
#include <algorithm>
#define SZ(x) ((int)(x).size())
#define ALL(v) (v).begin(), (v).end()
#define foreach(i, v) for (__typeof((v).begin()) i = (v).begin(); i != (v).end(); ++ i)
#define REP(i,n) for ( int i=1; i<=int(n); i++ )
using namespace std;
typedef long long ll;
#define X first
#define Y second
typedef pair<ll,ll> pii;


const int N = 1e5+100;

int sz[N*2];
int sz2[N*2];
int fa[N*2];
int n,m;
void ini(){
        REP(i,2*n) fa[i] = i;
        REP(i,2*n) sz[i] = (i <= n);
        REP(i,2*n) sz2[i] = (i > n);
}
int getf(int x){
        return x == fa[x] ? x : fa[x] = getf(fa[x]);
}
bool same(int a,int b){
        return getf(a) == getf(b);
}
void Merge(int a,int b){
        int f1 = getf(a), f2 = getf(b);
        if(f1 == f2) return ;
        fa[f1] = f2;
        sz[f2] += sz[f1];
        sz2[f2] += sz2[f1];
}
int main(){
        int T;
        cin>>T;
        while(T--){
                scanf("%d%d",&n,&m);
                ini();
                bool flag = 0;
                REP(i,m){
                        int a,b;
                        scanf("%d%d",&a,&b);
                        if(flag) continue;
                        if(same(a,b) || same(a+n,b+n) ) flag = 1;
                        else Merge(a+n,b),Merge(a,b+n);
                }
                if( n < 2 || flag) puts("Poor wyh");
                else if(m == 0) printf("%d 1\n",n-1);
                else {
                        int ans = 0;
                        REP(i,n){
                                if( fa[i] == i) ans += min(sz[i],sz2[i]);
                        }
                        printf("%d %d\n",n-ans,ans);
                }

        }
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值