POJ P1611 The Suspects 基础并查集

The Suspects
Time Limit: 1000MS Memory Limit: 20000K
Total Submissions: 19333 Accepted: 9376

Description

Severe acute respiratory syndrome (SARS), an atypical pneumonia of unknown aetiology, was recognized as a global threat in mid-March 2003. To minimize transmission to others, the best strategy is to separate the suspects from others. 
In the Not-Spreading-Your-Sickness University (NSYSU), there are many student groups. Students in the same group intercommunicate with each other frequently, and a student may join several groups. To prevent the possible transmissions of SARS, the NSYSU collects the member lists of all student groups, and makes the following rule in their standard operation procedure (SOP). 
Once a member in a group is a suspect, all members in the group are suspects. 
However, they find that it is not easy to identify all the suspects when a student is recognized as a suspect. Your job is to write a program which finds all the suspects.

Input

The input file contains several cases. Each test case begins with two integers n and m in a line, where n is the number of students, and m is the number of groups. You may assume that 0 < n <= 30000 and 0 <= m <= 500. Every student is numbered by a unique integer between 0 and n−1, and initially student 0 is recognized as a suspect in all the cases. This line is followed by m member lists of the groups, one line per group. Each line begins with an integer k by itself representing the number of members in the group. Following the number of members, there are k integers representing the students in this group. All the integers in a line are separated by at least one space. 
A case with n = 0 and m = 0 indicates the end of the input, and need not be processed.

Output

For each case, output the number of suspects in one line.

Sample Input

100 4
2 1 2
5 10 13 11 12 14
2 0 1
2 99 2
200 2
1 5
5 1 2 3 4 5
1 0
0 0

Sample Output

4
1
1

Source



题目大意:SARS病毒在学校中蔓延。学校的人分为好多个小组。如果一个小组有人患病,则整个小组都患病。0号本身患病(感染源。。。)多组输入输出。 要求患病的人数。


最基础的并查集习题。初学并查集可以刷这个

CODE:

#include <iostream>
using namespace std;

int set[30010];
int m,n,k,i,x,y,score;

int FindSet(int x);
void Union(int x,int y);
int main()
{
	while (cin>>n>>m && (n!=0)){
		for (i=0;i<n;++i)
			set[i]=i;
		for (i=0;i<m;++i){
			cin>>k; cin>>x; k--;
			while(k--){
				cin>>y;
				if (FindSet(y) != 0) Union(x,y);
				else Union(y,x);
			}
		}
		score=0;
		for (i=0;i<n;++i)
			if (FindSet(i) == 0) score++;
		cout<<score<<endl;
	}
	return 0;
}

int FindSet(int x){
	if (set[x] != x)
		set[x]=FindSet(set[x]);
	return set[x];
}

void Union(int x,int y){
	x = FindSet(x);
	y = FindSet(y);
	set[y] = x;
	return;
}

kdwycz的网站:  http://kdwycz.com/

kdwyz的刷题空间:http://blog.csdn.net/kdwycz



评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值