poj2442 Sequence(水题)

今天练习赛又碰见了这道水题,因为前几天刚做过所以想一A过掉,但是被卡了一个多小时,改了一个多小时才过,超不爽!以下是题目与及代码,坑点我会指出。

Sequence
Time Limit:6000MS     Memory Limit:65536KB     64bit IO Format:%I64d & %I64u

Description

Given m sequences, each contains n non-negative integer. Now we may select one number from each sequence to form a sequence with m integers. It's clear that we may get n ^ m this kind of sequences. Then we can calculate the sum of numbers in each sequence, and get n ^ m values. What we need is the smallest n sums. Could you help us?

Input

The first line is an integer T, which shows the number of test cases, and then T test cases follow. The first line of each case contains two integers m, n (0 < m <= 100, 0 < n <= 2000). The following m lines indicate the m sequence respectively. No integer in the sequence is greater than 10000.

Output

For each test case, print a line with the smallest n sums in increasing order, which is separated by a space.

Sample Input

1
2 3
1 2 3
2 2 3

Sample Output

3 3 4


/*这道题特别水,除了使用队列以外都是使用暴力*/


#include <iostream>
#include <cstdio>
#include <cstring>
#include <queue>
#include <algorithm>
using namespace std;
int a[2007], b[2007];
priority_queue<int, vector<int>, less<int> >p;
void F( int m)
{
    for( int i = 0, num = 0; i < m; i ++)
        for( int j = 0; j < m; j ++)
        {
            if(num < m) // 先把前M个塞到最大优先出队的队里;
            {
                p.push(a[i] + b[j]);
                num ++;
            }
            else if( a[i] + b[j] < p.top()) // 遇到和比队列P里最大值还要小的放进去,还要把原来的P里的最大值踢出来
            {
                p.pop();
                p.push(a[i] + b[j]);
            }
        }
    while(m --) // 从后往前放入a中
    {
        a[m] = p.top();
        p.pop();
    }
}
int main()
{
    int t, n, m;
    scanf("%d", &t);
    while(t --)
    {
        scanf("%d %d", &n, &m); // 这里我的N与M对调了,纯属个人习惯, 感觉这样比较顺眼
        for( int i = 0; i < m; i ++)
            scanf("%d", &a[i]);

        sort( a, a + m);  // 这个就是坑点,具体什么原因我也不明白,因为我是有优先队列做的,就算不排序也应该,没问题,但是没有这步我就是死活不能过
        while(-- n)
        {
            for( int i = 0; i < m; i ++)
                scanf("%d", &b[i]);
            F( m);
        }
        for( int i = 0; i < m; i ++)
        {
            if(i) printf(" ");
            printf("%d", a[i]);
        }
        printf("\n");
    }
    return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值