uva 568 Just the Facts(f分解因子)

737 篇文章 0 订阅
109 篇文章 2 订阅

  Just the Facts 

The expression  N !, read as `` N  factorial," denotes the product of the first  N  positive integers, where  N  is nonnegative. So, for example,

NN!
01
11
22
36
424
5120
103628800

For this problem, you are to write a program that can compute the last non-zero digit of any factorial for ( $0 \le N \le 10000$). For example, if your program is asked to compute the last nonzero digit of 5!, your program should produce ``2" because 5! = 120, and 2 is the last nonzero digit of 120.

Input 

Input to the program is a series of nonnegative integers not exceeding 10000, each on its own line with no other letters, digits or spaces. For each integer  N , you should read the value and compute the last nonzero digit of  N !.

Output 

For each integer input, the program should print exactly one line of output. Each line of output should contain the value  N , right-justified in columns 1 through 5 with leading blanks, not leading zeroes. Columns 6 - 9 must contain ``  ->  " (space hyphen greater space). Column 10 must contain the single last non-zero digit of  N !.

Sample Input 

1
2
26
125
3125
9999

Sample Output 

    1 -> 1
    2 -> 2
   26 -> 4
  125 -> 8
 3125 -> 2
 9999 -> 8
题目大意:给出n(n < 10000),求n!后面有多少个0。

解题思路:每乘一个数的时候就要进行判断,去除后面的0,因为n<10000,所以每次可以模掉10000.(10000刚好,1000会有误差)

#include<stdio.h>

int main(){
	int n;
	while (scanf("%d", &n) != EOF){
		int sum = 1;
		for (int i = 1; i <= n; i++){
			sum = sum * i;
			while (sum % 10 == 0){
				sum /= 10;
			}
			sum %= 100000;
		}
		printf("%5d -> %d\n", n, sum % 10);
	}
	return 0;
}
贴个牛叉的代码,用到分解因子。

#include<stdio.h>
int main()
{
   int n,i,num;
   while(scanf("%d",&n)!=EOF)
   {
      num=1;
      for(i=1;i<=n;i++)
      {
        if(i%5==0)
        {
           int x=i;
           while(x%10==0)
              x/=10;
           while(x%5==0)
           {
              x/=5;
              num/=2;
           }
           num*=x;
         }
         else
            num*=i;
         num%=100000;//一定要至少保留后五位非零位(五位以上要注意int型溢出,因此取五位最佳),因为后五位非零位的进位(极限情况3125,即5^5)会影响到最后的非零位
    }
   printf("%5d -> %d\n",n,num%10);
 }
return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值