poj 3041 Asteroids 二分图

19 篇文章 0 订阅
Asteroids
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 16923 Accepted: 9218

Description

Bessie wants to navigate her spaceship through a dangerous asteroid field in the shape of an N x N grid (1 <= N <= 500). The grid contains K asteroids (1 <= K <= 10,000), which are conveniently located at the lattice points of the grid. 

Fortunately, Bessie has a powerful weapon that can vaporize all the asteroids in any given row or column of the grid with a single shot.This weapon is quite expensive, so she wishes to use it sparingly.Given the location of all the asteroids in the field, find the minimum number of shots Bessie needs to fire to eliminate all of the asteroids.

Input

* Line 1: Two integers N and K, separated by a single space. 
* Lines 2..K+1: Each line contains two space-separated integers R and C (1 <= R, C <= N) denoting the row and column coordinates of an asteroid, respectively.

Output

* Line 1: The integer representing the minimum number of times Bessie must shoot.

Sample Input

3 4
1 1
1 3
2 2
3 2

Sample Output

2

Hint

INPUT DETAILS: 
The following diagram represents the data, where "X" is an asteroid and "." is empty space: 
X.X 
.X. 
.X.
 

OUTPUT DETAILS: 
Bessie may fire across row 1 to destroy the asteroids at (1,1) and (1,3), and then she may fire down column 2 to destroy the asteroids at (2,2) and (3,2).

给出一个图,上面有一些障碍点,每次可以消去一行或者一列障碍点,问最少操作多少次可以消除所有的障碍点。

如果把所有的行和列当做两组元素组,则每个障碍点就是连接二分图的边,由于最小点覆盖==最大匹配,则求二分图的最大匹配就可以啦~\(≧▽≦)/~啦啦啦 可以采用dfs求二分图最大匹配。。

#include <iostream>
#include <stdio.h>
#include <algorithm>
#include <string.h>
#include <set>
#include <queue>
#include <vector>
#include <map>
#include <stack>
#include <stdlib.h>
#include <math.h>
using namespace std;
#define Max 520
int mp[Max][Max];
int cx[Max],cy[Max];
int vis[Max];
int n,m,x,y;
bool dfs(int u)
{
	for(int v=1;v<=n;v++)
	{
		if(mp[u][v]&&!vis[v])
		{
			vis[v]=1;
			if(cy[v]==0||dfs(cy[v]))
			{
				cx[u]=v;
				cy[v]=u;
				return true;
			}
		}
	}
	return false;
}
int main()
{
	cin>>n>>m;
	for(int i=1;i<=m;i++)
	{
		cin>>x>>y;
		mp[x][y]=1;
	}
	int res=0;
	for(int i=1;i<=n;i++)
	{
		memset(vis,0,sizeof(vis));
		if(dfs(i)) res++;
	}
	cout<<res<<endl;
	return 0;
}







评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值