线段树- Lost Cows

Lost Cows
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 1876 Accepted: 1163

Description
N (2 <= N <= 8,000) cows have unique brands in the range 1..N. In a spectacular display of poor judgment, they visited the neighborhood 'watering hole' and drank a few too many beers before dinner. When it was time to line up for their evening meal, they did not line up in the required ascending numerical order of their brands.

Regrettably, FJ does not have a way to sort them. Furthermore, he's not very good at observing problems. Instead of writing down each cow's brand, he determined a rather silly statistic: For each cow in line, he knows the number of cows that precede that cow in line that do, in fact, have smaller brands than that cow.

Given this data, tell FJ the exact ordering of the cows.

Input
* Line 1: A single integer, N

* Lines 2..N: These N-1 lines describe the number of cows that precede a given cow in line and have brands smaller than that cow. Of course, no cows precede the first cow in line, so she is not listed. Line 2 of the input describes the number of preceding cows whose brands are smaller than the cow in slot #2; line 3 describes the number of preceding cows whose brands are smaller than the cow in slot #3; and so on.

Output
* Lines 1..N: Each of the N lines of output tells the brand of a cow in line. Line #1 of the output tells the brand of the first cow in line; line 2 tells the brand of the second cow; and so on.

Sample Input

 

Sample Output

 

Source
USACO 2003 U S Open Orange

 解答方案

从后往前看,选择排名同输入相同的元素,然后从序列中删除此元素,进行重新选择。

比如:

n = 3

序列1 2 3中每个元素前面大于它的元素个数分别为0 1 2

输入为:0 1 1

则从最后一个1开始向前看,1 2 3 中前面大于该元素的元素个数为1的为数字1,因此选择数字1,然后将1从序列中删除(1 2 3->2 3,0 1 2->0 1)。然后看倒数第二个1。依此类推。

Code:

#include <stdio.h>
#include <string.h>

#define MAXN 8000

typedef struct
{
 int val;
 int index;
}treeNode;

static treeNode T[MAXN];
static int tlen;
static int input[MAXN];
static int output[MAXN];

static void buildT();
static void reorder(int );


int main(int argc,char **argv)
{
 int i,n;

 scanf("%d",&n);
 tlen = n;
 buildT();
 input[0] = 0;
 for(i=1;i<tlen;i++)
 {
  scanf("%d",&input[i]);
 }

    for(i=tlen-1;i>=0;i--)
 {
  reorder(i);
 }

 for(i=0;i<n;i++)
  printf("%d/n",output[i]);

 return 0;
}

static void buildT()
{
 for(int i=0;i<tlen;i++)
 {
  T[i].val = i;
  T[i].index = i+1;
 }
}

static void reorder(int index)
{
 int t = input[index];
 /*二分查找*/
 int low,hig,mid;
 bool found;

 low = 0;
 hig = tlen-1;
 found = false;

 while(low<=hig&&!found)
 {
  mid = (low+hig)>>1;
  if(T[mid].val==t)
   found = true;
  else if(T[mid].val<t)
   low = mid + 1;
  else
   hig = mid -1;
 }

 if(!found)
  return;

 output[index] = T[mid].index;
 
 for(int i=mid+1;i<tlen;i++)
 {
  memcpy(&T[i-1],&T[i],sizeof(treeNode));
  T[i-1].val--;
 }
 tlen -- ;
}

采用线段树的实现:

 

2
4
5
3
1

5
1
2
1
0
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 12
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论 12
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值