hdu 3415 Max Sum of Max-K-sub-sequence 单调队列 求连续l(1<=l<=k)个数的和的最大值 数列可循环

Max Sum of Max-K-sub-sequence

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 1188    Accepted Submission(s): 426

Problem Description
Given a circle sequence A[1],A[2],A[3]......A[n]. Circle sequence means the left neighbour of A[1] is A[n] , and the right neighbour of A[n] is A[1].
Now your job is to calculate the max sum of a Max-K-sub-sequence. Max-K-sub-sequence means a continuous non-empty sub-sequence which length not exceed K.
 

 

Input
The first line of the input contains an integer T(1<=T<=100) which means the number of test cases.
Then T lines follow, each line starts with two integers N , K(1<=N<=100000 , 1<=K<=N), then N integers followed(all the integers are between -1000 and 1000).
 

 

Output
For each test case, you should output a line contains three integers, the Max Sum in the sequence, the start position of the sub-sequence, the end position of the sub-sequence. If there are more than one result, output the minimum start position, if still more than one , output the minimum length of them.
 

 

Sample Input
  
  
4 6 3 6 -1 2 -6 5 -5 6 4 6 -1 2 -6 5 -5 6 3 -1 2 -6 5 -5 6 6 6 -1 -1 -1 -1 -1 -1
 

 

Sample Output
  
  
7 1 3 7 1 3 7 6 2 -1 1 1
#include<iostream>
#include<cstdio>
#include<cstring>
using namespace std;
const int inf=(1<<31)-1;
int Q[210000],I[210000];//最小单调队列
int a[210000],sum[210000];
int main()
{
    int ci;scanf("%d",&ci);
    while(ci--)
    {
        int n,k;scanf("%d%d",&n,&k);
        int start,end;
        for(int i=1;i<=n;i++)
        {
            scanf("%d",&a[i]);
            sum[i]=sum[i-1]+a[i];
        }
        for(int i=n+1;i<=2*n;i++) sum[i]=sum[i-1]+a[i-n];
        int head=0,tail=-1;
        int _max=-inf;
        for(int j=1;j<n+k;j++)//枚举尾点 求sum[j]-sum[i-1] 的最大值(j-k=< i <= j-1)
        {
            int i=j-1;//sum[j-1]入队
            while(head<=tail&&Q[tail]>=sum[i]) tail--;
            tail++;
            Q[tail]=sum[i];I[tail]=i;
            i=j-k-1;//出队
            while(head<=tail&&I[head]<=i) head++;
            int _res=sum[j]-Q[head];//注意是Q[head]存最小值
            if(_res>_max)
            {
                _max=_res;
                start=I[head]+1,end=j;//注意是I[head]存最小值的坐标
                if(end>n) end-=n;
            }
        }
        printf("%d %d %d/n",_max,start,end);
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值