hdu 3927 Math Geek 反幻方构造

Problem Description
Sheldon's board has been changed! Someone drew a N * N grid on his board. Although he has no idea who's the bad guy, but as a math geek, he decide to play a game on it. He will fill in the grids with integer 1 to N*N. And the sum of each row, each column and each diagonal are distinct (2N+2 distinct integers in total).
 


 

Input
The first line contains a single positive integer T( T <= 200 ), indicates the number of test cases.
For each test case: an integer N (3 <= N <= 200).
 


 

Output
For each test case: output the case number as shown and an N * N matrix.
The output must contains N+1 lines, or you maybe get wrong answer because of special judge.
The numbers in each line must be separated by a blankspace or a tab. leading and trailing blankspace will be ignored.
 


 

Sample Input
  
  
2 3 4
 


 

Sample Output
  
  
Case #1: 7 5 2 1 4 8 3 6 9 Case #2: 2 8 15 1 5 12 10 16 6 9 4 14 3 7 11 13

 

 

 //

 

#include <cstdio>
int main()
{
    int T;
    int cas = 1;
    scanf("%d", &T);
    while(T--)
    {
        int n;
        scanf("%d", &n);
        printf("Case #%d:\n",cas++);
        for(int i = 1; i <= n; i++)
        {
            for(int j = 1; j < n; j++)
            {
                printf("%d ", (i-1)*(n-1)+j);
            }
            printf("%d\n", n*(n-1)+i);
        }
    }
    return 0;
}

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值