POJ Balanced Lineup 3264

6 篇文章 0 订阅
1 篇文章 0 订阅

                                                             

Balanced Lineup
Time Limit: 5000MS Memory Limit: 65536K
Total Submissions: 48372 Accepted: 22684
Case Time Limit: 2000MS

Description

For the daily milking, Farmer John's N cows (1 ≤ N ≤ 50,000) always line up in the same order. One day Farmer John decides to organize a game of Ultimate Frisbee with some of the cows. To keep things simple, he will take a contiguous range of cows from the milking lineup to play the game. However, for all the cows to have fun they should not differ too much in height.

Farmer John has made a list of Q (1 ≤ Q ≤ 200,000) potential groups of cows and their heights (1 ≤height ≤ 1,000,000). For each group, he wants your help to determine the difference in height between the shortest and the tallest cow in the group.

Input

Line 1: Two space-separated integers, N and Q.
Lines 2.. N+1: Line i+1 contains a single integer that is the height of cow i
Lines N+2.. N+ Q+1: Two integers A and B (1 ≤ ABN), representing the range of cows from A to B inclusive.

Output

Lines 1.. Q: Each line contains a single integer that is a response to a reply and indicates the difference in height between the tallest and shortest cow in the range.

Sample Input

6 3
1
7
3
4
2
5
1 5
4 6
2 2

Sample Output

6
3
0

Source


题意:给定区间,求区间最大最小值的差

分析:可以用线段树做,没有更新

   也可以用RMQ,代码也不多

//线段树

#include <iostream>
#include <algorithm>
#include <stdio.h>
#include <stdlib.h>
using namespace std;
#define lson l,m,rt<<1
#define rson m+1,r,rt<<1|1
#define maxx 51000
#define inf 1123456
long long Max[maxx<<2];
long long Min[maxx<<2];
void gengxin(int rt)
{
    Max[rt]=max(Max[rt<<1],Max[rt<<1|1]);
    Min[rt]=min(Min[rt<<1],Min[rt<<1|1]);
}
void build(int l,int r,int rt)
{
    if(l==r)
    {
        scanf("%lld",&Max[rt]);
        Min[rt]=Max[rt];
        
        return ;
    }
    int m=(l+r)>>1;
    build(lson);
    build(rson);
    gengxin(rt);
}
long long querymax(int x,int y,int l,int r,int rt)
{
    if(x<=l&&r<=y)
    {
        return Max[rt];
       // printf("%lld\n",Max[rt]);
    }

    int m=(l+r)>>1;
    long long ret=-inf;
    if(x<=m)
         ret=max(ret,querymax(x,y,lson));
    if(m<y)
         ret=max(ret,querymax(x,y,rson));

    return ret;
}
long long querymin(int x,int y,int l,int r,int rt)
{
    if(x<=l&&r<=y)
    {
        return Min[rt];
    }
    int m=(l+r)>>1;
    long long ret=inf;
    if(x<=m)
         ret=min(ret,querymin(x,y,lson));
    if(m<y)
         ret=min(ret,querymin(x,y,rson));
    return ret;
}
int main()
{
    int n,m,i,j,x,y;
    while(~scanf("%d%d",&n,&m))
    {
    build(1,n,1);
    while(m--)
    {
        scanf("%d%d",&x,&y);
        long long l=querymax(x,y,1,n,1);
        long long s=querymin(x,y,1,n,1);;
        printf("%lld\n",l-s);

    }
    }
    return 0;
}

//RMQ

#include <iostream>
#include <stdio.h>
#include <algorithm>
#include <math.h>
using namespace std;
//F[i][j]代表【i,i+(1<<j)+1】区间中的最值
int Fmax[51234][20];
int Fmin[51234][20];

void f(int n)
{
    int i,j;
    for(j=1;j!=20;j++)
    {
        for(i=1;i<=n;i++)
        {
            if(i+(1<<j)-1<=n)
            {
                //所以是j-1,前面的要加上
                Fmax[i][j]=max(Fmax[i][j-1],Fmax[i+(1<<(j-1))][j-1]);
                Fmin[i][j]=min(Fmin[i][j-1],Fmin[i+(1<<(j-1))][j-1]);
            }

        }
    }
}

int main()
{
    int n,m,i,j;
    int a,b;
    scanf("%d%d",&n,&m);
    for(i=1;i<=n;i++)
    {
        scanf("%d",&Fmax[i][0]);
        Fmin[i][0]=Fmax[i][0];
    }
    f(n);
    while(m--)
    {
        scanf("%d%d",&a,&b);
        int k;
        k=int(log(b-a+1.0)/log(2.0));
        int maxx=max(Fmax[a][k],Fmax[b-(1<<k)+1][k]);
        int minn=min(Fmin[a][k],Fmin[b-(1<<k)+1][k]);
        printf("%d\n",maxx-minn);
    }
    return 0;
}





  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值