【PAT甲】A1058、A1027

22 篇文章 0 订阅
/*
*时间:2018年4月26日22:07:23-2018年4月26日22:31:55
*题目:1027.Colors in Mars
*分数:20
*编译器:g++
*题目描述:
People in Mars represent the colors in their computers in a similar way as the Earth people. 
That is, a color is represented by a 6-digit number, where the first 2 digits are for Red,
 the middle 2 digits for Green, and the last 2 digits for Blue. The only difference is that 
 they use radix 13 (0-9 and A-C) instead of 16. Now given a color in three decimal numbers (each between 0 and 168),
 you are supposed to output their Mars RGB values.

Input

Each input file contains one test case which occupies a line containing the three decimal color values.

Output

For each test case you should output the Mars RGB value in the following format: first output "#", then followed by a 6-digit
 number where all the English characters must be upper-cased. If a single color is only 1-digit long, you must print a "0" to the left.
Sample Input

15 43 71

Sample Output

#123456
*/
//思路:这题比普通的进制转换题多了一点难点就是要自己写输出ABC,自然就想到了简历一个13进制的数组
//好像枚举的话感觉会更高端一些
#include <iostream>
using namespace std;
#include <vector>
char radix13[13] = {'0', '1', '2', '3', '4', '5', '6', '7', '8', '9', 'A', 'B', 'C'};//13进制的数组
void printRadix13(int a)//打印13进制的数
{
	vector<int> v;//为了倒序打印
	int shang = a;
	int res;
	do{
		res = shang % 13;
		shang = shang / 13;
		v.push_back(res);	
	}while(shang);
	if (v[1] == '\0') cout<<"0"<<radix13[v[0]];	//处理第一位为0的情况
	else cout<<radix13[v[1]]<<radix13[v[0]];
}
int main()
{
	int a, b, c;
	cin>>a>>b>>c;
	cout<<"#";
	printRadix13(a);
	printRadix13(b);
	printRadix13(c);
	return 0;
}

/*
*时间:2018年4月26日22:36:17-2018年4月26日22:43:24
*题目:1058.A+B in Hogwarts
*分数:20
*编译器:g++
*题目描述:
If you are a fan of Harry Potter, you would know the world of magic has its own currency system -- 
as Hagrid explained it to Harry, "Seventeen silver Sickles to a Galleon and twenty-nine Knuts to a Sickle,
 it's easy enough." Your job is to write a program to compute A+B where A and B are given in the standard form 
 of "Galleon.Sickle.Knut" (Galleon is an integer in [0, 107], Sickle is an integer in [0, 17), and Knut is an integer in [0, 29)).

Input Specification:

Each input file contains one test case which occupies a line with A and B in the standard form, separated by one space.

Output Specification:

For each test case you should output the sum of A and B in one line, with the same format as the input.
Sample Input:

3.2.1 10.16.27

Sample Output:

14.1.28
*/
//思路:这题乍一看和PAT乙级的那题找钱的一样,不过这题还更简单了一点,本来不想做了的
//后来还是试了下,发现虽然做过,但是每次还是会有新的想法
#include <iostream>
using namespace std;
#include <stdio.h>
int main()
{
	int a[3];
	int b[3];
	int c[3];
	int flag = 0;
	scanf("%d.%d.%d %d.%d.%d",&a[0], &a[1], &a[2], &b[0], &b[1], &b[2]);//大赞scanf
	c[2] = (a[2] + b[2]) % 29;//第三位计算
	flag = (a[2] + b[2]) / 29;//计算进位,下面类似
	c[1] = (a[1] + b[1] + flag) % 17;
	flag = (a[1] + b[1] + flag) / 17;
	c[0] = (a[0] + b[0]) + flag;
	cout<<c[0]<<"."<<c[1]<<"."<<c[2];
	
	return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值