PAT A1064 Complete Binary Search Tree (30分)

PAT A1064 Complete Binary Search Tree 30分

原题

A Binary Search Tree (BST) is recursively defined as a binary tree which has the following properties:
The left subtree of a node contains only nodes with keys less than the node’s key.
The right subtree of a node contains only nodes with keys greater than or equal to the node’s key.
Both the left and right subtrees must also be binary search trees.
A Complete Binary Tree (CBT) is a tree that is completely filled, with the possible exception of the bottom level, which is filled from left to right.
Now given a sequence of distinct non-negative integer keys, a unique BST can be constructed if it is required that the tree must also be a CBT. You are supposed to output the level order traversal sequence of this BST.
Input Specification:
Each input file contains one test case. For each case, the first line contains a positive integer N (≤1000). Then N distinct non-negative integer keys are given in the next line. All the numbers in a line are separated by a space and are no greater than 2000.
Output Specification:
For each test case, print in one line the level order traversal sequence of the corresponding complete binary search tree. All the numbers in a line must be separated by a space, and there must be no extra space at the end of the line.
Sample Input:

10
1 2 3 4 5 6 7 8 9 0

Sample Output:

6 3 8 1 5 7 9 0 2 4

大体题意

对象为完全二叉排序树,给定其建树顺序,要求输出其层序遍历

思路

完全二叉排序树有隐含的性质:
1.二叉排序树的中序遍历就是从小到大输出
2.完全二叉树的根结点和孩子结点在层序序列数组中的下标是有关系的
因此我们研究完全二叉排序树的结构,得出其中序遍历和层序遍历的关系即可
在这里插入图片描述
假设中序序列用数组a[]表示,层序序列有数组b[]表示,则它们的对应关系如图所示。
在层序序列中,对于根结点b[i]而言,其左子树为b[2i+1],右子树为b[2i+2]
一般的中序遍历的代码如下:

//递归的中序遍历
void InOrder(BiTree T)
{
	if (T != NULL)
	{
		InOrder(T->lchild);
		cout << T->data << " ";//就是这里
		InOrder(T->rchild);
	}
}

从b[0]开始中序遍历,则最先得到的,即最先输出的一定是最左下的数值,也就是最小的数,结束的条件就是i<n
在原先中序遍历输出的部分,替换成将b[i] = a[k++]即可,k从0开始
而左子树对应的参数就是2*i+1,右子树对应的参数就是2*i+2

代码

#include<iostream>
using namespace std;
#include <algorithm>

int n;
int a[1005], b[1005];
int k = 0;
void inorder(int root)
{
	if (root < n)
	{
		//不断求左孩子在中序遍历里的位置/最后会是最小值,最小值在a中的位置是0
		inorder(root * 2 + 1);
		b[root] = a[k++];//上一层
		inorder(root * 2 + 2);//右边
	}
}

int main()
{
	cin >> n;
	for (int i = 0; i < n; i++)
		cin >> a[i];
	sort(a, a + n);//将输入从小到大排序,才是中序序列
	inorder(0);
	int i;
	for (i = 0; i < n - 1; i++)
		cout << b[i] << " ";
	cout << b[i] << endl;
	return 0;
}

运行结果

在这里插入图片描述

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值