hdu1285 确定比赛名次 拓扑排序学习 待补完

确定比赛名次

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 23153    Accepted Submission(s): 9378


Problem Description
有N个比赛队(1<=N<=500),编号依次为1,2,3,。。。。,N进行比赛,比赛结束后,裁判委员会要将所有参赛队伍从前往后依次排名,但现在裁判委员会不能直接获得每个队的比赛成绩,只知道每场比赛的结果,即P1赢P2,用P1,P2表示,排名时P1在P2之前。现在请你编程序确定排名。
 

Input
输入有若干组,每组中的第一行为二个数N(1<=N<=500),M;其中N表示队伍的个数,M表示接着有M行的输入数据。接下来的M行数据中,每行也有两个整数P1,P2表示即P1队赢了P2队。
 

Output
给出一个符合要求的排名。输出时队伍号之间有空格,最后一名后面没有空格。

其他说明:符合条件的排名可能不是唯一的,此时要求输出时编号小的队伍在前;输入数据保证是正确的,即输入数据确保一定能有一个符合要求的排名。
 

Sample Input
  
  
4 3 1 2 2 3 4 3
 

Sample Output
  
  
1 2 4 3
 

Author
SmallBeer(CML)
 

Source



无限WA 的dfs版本:

#include <iostream>
#include <cstring>
#include <cstdio>
#include <algorithm>
#include <vector>
#include <cmath>
#include <map>
#include <set>
using namespace std;
const double pi = 3.14159265358979323846264338327950288419716939937511;
const double eps = 1e-8;
//抄个模版也能错真是日了狗了
const int maxn = 510;
int c[maxn],n;
int topo[maxn],t;
bool G[maxn][maxn];
bool dfs(int u){
    c[u]=-1;//been visited
    for(int v=1;v<=n;v++){
        if(G[u][v]){
            if(c[v]<0){
                return false;
            }else if(!c[v]&&!dfs(v)){
                return false;
            }
        }
    }
    c[u]=1;
    topo[t--]=u;
    return true;
}
bool topoSort(){
    t = n;
    memset(c, 0, sizeof(c));
    for(int u=n;u>=1;u--){
        if(!c[u]){
            if(!dfs(u)){
                return false;
            }
        }
    }
    return true;
}
int main(){
    int m;
    while(~scanf("%d%d",&n,&m)){
        int i;
        memset(G, false, sizeof(G));
        memset(topo, 0, sizeof(topo));
        for(i=1;i<=m;i++){
            int a,b;
            scanf("%d%d",&a,&b);
            G[a][b]=true;
        }
        topoSort();
        for(i=1;i<=n;i++){
            printf("%d%c",topo[i],i==n?'\n':' ');
        }
    }
    return 0;
}

在讨论版里找到了一个反例子:

给组数据
5 4
5 2
5 3
2 4
3 1

正确输出
5 2 3 1 4
dfs版本输出:

5 3 1 2 4



1A的感觉不高端版本:

#include <iostream>
#include <cstring>
#include <cstdio>
#include <algorithm>
#include <vector>
#include <cmath>
#include <map>
#include <set>
using namespace std;
const double pi = 3.14159265358979323846264338327950288419716939937511;
const double eps = 1e-8;
//抄个模版也能错真是日了狗了
const int maxn = 510;
int c[maxn],n;
int topo[maxn],t;
bool G[maxn][maxn];
int rudu[maxn];
void topoSort(){
    int i,j,k;
    for(i=1;i<=n;i++){
        j=1;
        while(rudu[j]!=0){
            j++;
        }
        topo[i]=j;
        rudu[j]--;
        for(k=1;k<=n;k++){
            if(G[j][k]){
                rudu[k]--;
            }
        }
    }
}
int main(){
    int m;
    while(~scanf("%d%d",&n,&m)){
        int i;
        memset(G, false, sizeof(G));
        memset(rudu, 0, sizeof(rudu));
        for(i=1;i<=m;i++){
            int a,b;
            scanf("%d%d",&a,&b);
            if(!G[a][b]){
                G[a][b]=true;
                rudu[b]++;
            }
        }
        topoSort();
        for(i=1;i<=n;i++){
            printf("%d%c",topo[i],i==n?'\n':' ');
        }
    }
    return 0;
}






  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值