POJ - 3069 Saruman‘s Army(贪心法)

21 篇文章 0 订阅
14 篇文章 0 订阅

点击打开题目链接

Saruman's Army
Time Limit: 1000MSMemory Limit: 65536K
Total Submissions: 9820Accepted: 4942

Description

Saruman the White must lead his army along a straight path from Isengard to Helm’s Deep. To keep track of his forces, Saruman distributes seeing stones, known as palantirs, among the troops. Each palantir has a maximum effective range of R units, and must be carried by some troop in the army (i.e., palantirs are not allowed to “free float” in mid-air). Help Saruman take control of Middle Earth by determining the minimum number of palantirs needed for Saruman to ensure that each of his minions is within R units of some palantir.

Input

The input test file will contain multiple cases. Each test case begins with a single line containing an integer R, the maximum effective range of all palantirs (where 0 ≤ R ≤ 1000), and an integer n, the number of troops in Saruman’s army (where 1 ≤ n ≤ 1000). The next line contains n integers, indicating the positions x1, …, xn of each troop (where 0 ≤ xi ≤ 1000). The end-of-file is marked by a test case with R = n = −1.

Output

For each test case, print a single integer indicating the minimum number of palantirs needed.

Sample Input

0 3
10 20 20
10 7
70 30 1 7 15 20 50
-1 -1

Sample Output

2
4

Hint

In the first test case, Saruman may place a palantir at positions 10 and 20. Here, note that a single palantir with range 0 can cover both of the troops at position 20.

In the second test case, Saruman can place palantirs at position 7 (covering troops at 1, 7, and 15), position 20 (covering positions 20 and 30), position 50, and position 70. Here, note that palantirs must be distributed among troops and are not allowed to “free float.” Thus, Saruman cannot place a palantir at position 60 to cover the troops at positions 50 and 70.

本想梳理一下中国剩余定理的相关知识,但是由于今天集训了一天,脑子cpu已经烧掉了,所以找到一个比较简单的贪心的题目。

题目大意为:一条直线上有n个点,要求标记其中某些点使得对于直线上的每个点,在距离R内至少有一个被标记的点。求出标记最少的次数。

求局部最优解的问题,从第一个点开始,标记的点一定在它的右边或者是它自己,然后以标记点为起点,标记最右边一个可以满足差值小于R的点,依次向右延伸。

附上AC代码:

#include<bits/stdc++>

using namespace std;
const int maxn=1000+5;
int r,n;
int pos[maxn];

int main()
{
    while(scanf("%d%d",&r,&n)!=EOF&&r!=-1)
    {
        int ans=0;
        for(int i=0;i<n;i++)
            cin>>pos[i];
        sort(pos,pos+n);
        
        int l=0;
        while(l<n)
        {
            int temp=pos[l];
            while(pos[l]-temp<=r) l++;
            temp=pos[l-1];
            while(pos[l]-temp<=r) l++;
            ans++;
        }
        printf("%d\n",ans);
    }
    return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

Chook_lxk

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值