POJ - 3723 Conscription(最大生成树Kruskal)

点击打开题目链接

Conscription
Time Limit: 1000MSMemory Limit: 65536K
Total Submissions: 13061Accepted: 4581

Description

Windy has a country, and he wants to build an army to protect his country. He has picked up N girls and M boys and wants to collect them to be his soldiers. To collect a soldier without any privilege, he must pay 10000 RMB. There are some relationships between girls and boys and Windy can use these relationships to reduce his cost. If girl x and boy y have a relationship d and one of them has been collected, Windy can collect the other one with 10000-d RMB. Now given all the relationships between girls and boys, your assignment is to find the least amount of money Windy has to pay. Notice that only one relationship can be used when collecting one soldier.

Input

The first line of input is the number of test case.
The first line of each test case contains three integers, NM and R.
Then R lines followed, each contains three integers xiyi and di.
There is a blank line before each test case.

1 ≤ NM ≤ 10000
0 ≤ R ≤ 50,000
0 ≤ xi < N
0 ≤ yi < M
0 < di < 10000

Output

For each test case output the answer in a single line.

Sample Input

2

5 5 8
4 3 6831
1 3 4583
0 0 6592
0 1 3063
3 3 4975
1 3 2049
4 2 2104
2 2 781

5 5 10
2 4 9820
3 2 6236
3 1 8864
2 4 8326
2 0 5156
2 0 1463
4 1 2439
0 4 4373
3 4 8889
2 4 3133

Sample Output

71071
54223

Source

[Submit]   [Go Back]   [Status]   [Discuss]

听到别人说Kruskal算法,然而我并不知道这是什么东西(TAT),赛后发现就是并查集加上一个函数。(QAQ脑补)

题目大意:有一个城镇要组织军队,招收N名女人和M名男人,原本每人费用10000元,但如果女人和男人有关系d且其中一个已经被招收,则另外一个只需要10000-d元,求出需要最少的招收费用。

思路:用一个结构体存下某种关系,因为要使得花费最少,所以d要从大到小排一下序,然后用两个集合i-x和i-y建立并查集,表示x和y其中一个已经被招收,一个没有被招收,然后求和把d加起来,再把x和y组合。最后用原总费用减去sum即可。这次又差一点忘了数组开两倍,一次CE,原因init初始值的函数写的int类型,但没有返回值(TAT)

附上AC代码:

#include<iostream>
#include<cstdio>
#include<vector>
#include<algorithm>

using namespace std;
const int maxn=10000;
int par[maxn*2+10];
int N,M,R;

struct army{
int women,man,money;
};

bool cmp(const army a,const army b)
{
    return a.money>b.money;
}

void init()
{
    for(int i=0;i<=2*maxn;i++)
        par[i]=i;
}

int find(int a)
{
    if(a==par[a]) return a;
    else return par[a]=find(par[a]);
}

void unite(int a,int b)
{
    a=find(a);
    b=find(b);
    if(a==b)return ;
    par[a]=b;
}

bool same(int a,int b)
{
    return find(a)==find(b)?true:false;
}

int main()
{
    int T;
    vector<army> v;
    scanf("%d",&T);

    while(T--)
    {
        army ar;
        int sum_m=0;
        scanf("%d%d%d",&N,&M,&R);
        init();
        v.clear();
        for(int i=0;i<R;i++)
        {
            scanf("%d%d%d",&ar.women,&ar.man,&ar.money);
            ar.man+=N;
            v.push_back(ar);
        }

        sort(v.begin(),v.end(),cmp);
        for(int i=0;i<v.size();i++)
        {
            if(same(v[i].women,v[i].man)==0)
            {
                unite(v[i].women,v[i].man);
                sum_m+=v[i].money;
            }
        }
        int ans=(N+M)*10000-sum_m;
        printf("%d\n",ans);
    }
    return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

Chook_lxk

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值