POJ - 1035 Spell checker(水+字符串字典)

点击打开题目链接

Spell checker
Time Limit: 2000MSMemory Limit: 65536K
Total Submissions: 25501Accepted: 9329

Description

You, as a member of a development team for a new spell checking program, are to write a module that will check the correctness of given words using a known dictionary of all correct words in all their forms. 
If the word is absent in the dictionary then it can be replaced by correct words (from the dictionary) that can be obtained by one of the following operations: 
?deleting of one letter from the word; 
?replacing of one letter in the word with an arbitrary letter; 
?inserting of one arbitrary letter into the word. 
Your task is to write the program that will find all possible replacements from the dictionary for every given word. 

Input

The first part of the input file contains all words from the dictionary. Each word occupies its own line. This part is finished by the single character '#' on a separate line. All words are different. There will be at most 10000 words in the dictionary. 
The next part of the file contains all words that are to be checked. Each word occupies its own line. This part is also finished by the single character '#' on a separate line. There will be at most 50 words that are to be checked. 
All words in the input file (words from the dictionary and words to be checked) consist only of small alphabetic characters and each one contains 15 characters at most. 

Output

Write to the output file exactly one line for every checked word in the order of their appearance in the second part of the input file. If the word is correct (i.e. it exists in the dictionary) write the message: " is correct". If the word is not correct then write this word first, then write the character ':' (colon), and after a single space write all its possible replacements, separated by spaces. The replacements should be written in the order of their appearance in the dictionary (in the first part of the input file). If there are no replacements for this word then the line feed should immediately follow the colon.

Sample Input

i
is
has
have
be
my
more
contest
me
too
if
award
#
me
aware
m
contest
hav
oo
or
i
fi
mre
#

Sample Output

me is correct
aware: award
m: i my me
contest is correct
hav: has have
oo: too
or:
i is correct
fi: i
mre: more me

Source

[Submit]   [Go Back]   [Status]   [Discuss]

题目大意:首先给你多个字典中的字符串,然后给你需要判断的字符串,判断字典中是否有该字符串,如果没有,判断是否可以通过字符串的增删一个字符或改变一个字符得到目标字符串。

字符串比较的水题。写两个比较函数分别比较字符串长度相等的情况和长度差1的情况即可。

附上AC代码:

#include<iostream>
#include<string>

using namespace std;
const int maxn=10000+5;
string s[maxn];
string st;

int cmp(string &a,string &b)
{
        int sum=0;
        for(int i=0;i<int(a.length());i++)
        {
            if(a[i]!=b[i])sum++;
            if(sum>1)return 0;
        }
    return 1;
}

int cmp1(string &a,string &b)
{
    int sum=0;
        for(int i=0,j=0;i<int(a.length());)
        {
             if(a[i]!=b[j])
             {
                 sum++;
                 i++;
             }
             else if(a[i]==b[j]){i++;j++;}
             if(sum>1)return 0;
        }
    return 1;
}

int main()
{
    ios::sync_with_stdio(false);
//    freopen("in.txt","r",stdin);
    int cnt=0;
    while(cin>>st&&st[0]!='#')
    {
        s[cnt++]=st;
//        sort(s,s+cnt);
    }
    
    while(cin>>st&&st[0]!='#')
    {
        int flag=0;
        for(int i=0;i<cnt;i++)
        {
            if(s[i]==st)
            {
                flag=2;break;
            }
            else if(st.length()==s[i].length())
            {
                if(cmp(st,s[i]))
                flag=1;
            }
            else if(st.length()>s[i].length())
            {
                if(cmp1(st,s[i]))
                    flag=1;
            }
            else if(st.length()<s[i].length())
            {
                if(cmp1(s[i],st))
                    flag=1;
            }
        }
        
        if(flag==2)cout<<st<<" is "<<"correct"<<endl;
        else if(flag==0)cout<<st<<":"<<endl;
        else
        {
            cout<<st<<":";
            for(int i=0;i<cnt;i++)
            {
                if(st.length()>s[i].length())
                {
                    if(cmp1(st,s[i]))
                    cout<<" "<<s[i];
                }
                else if(st.length()<s[i].length())
                {
                     if(cmp1(s[i],st))
                    cout<<" "<<s[i];
                }
                else if(st.length()==s[i].length())
                {
                     if(cmp(s[i],st))
                    cout<<" "<<s[i];
                }
            }
            cout<<endl;
        }
    }
    return 0;
}

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

Chook_lxk

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值