LightOJ 1067 Combinations(费马小定理+逆元)

M - Combinations
Time Limit:2000MS Memory Limit:32768KB 64bit IO Format:%lld & %llu

Description
Given n different objects, you want to take k of them. How many ways to can do it?

For example, say there are 4 items; you want to take 2 of them. So, you can do it 6 ways.

Take 1, 2
Take 1, 3
Take 1, 4
Take 2, 3
Take 2, 4
Take 3, 4

Input
Input starts with an integer T (≤ 2000), denoting the number of test cases.

Each test case contains two integers n (1 ≤ n ≤ 10^6), k (0 ≤ k ≤ n).

Output
For each case, output the case number and the desired value. Since the result can be very large, you have to print the result modulo 1000003.

Sample Input
3
4 2
5 0
6 4
Sample Output
Case 1: 6
Case 2: 1
Case 3: 15


题意便是求C(a,b)了
Lucas定理可知:
c(a,b) = ( (a! * ((a-b)!)^(p-2) % mod) * ((b!)^(p-2)) ) % mod;

#include<cstdio>
#include<iostream>
#include<cstring>
#include<cmath>
#include<algorithm>
using namespace std;
const int MAX = 1e6+100;
const int MOD = 1000003;
long long a[MAX];
long long b[MAX];
long long Pow(long long a,long long b)
{
    long long ans = 1;
    while(b)
    {
        if(b&1)
            ans=(ans*a)%MOD;
        a=(a*a)%MOD;
        b>>=1;
    }
    return ans;
}
void init()
{
    a[0]=1;
    b[0]=1;
    for(int i=1;i<=1000100;i++)
    {
        a[i]=(a[i-1]*i)%MOD;
        b[i]=Pow(a[i],MOD-2);
    }
}
int main()
{
    int t;
    int Case=1;
    init();
    scanf("%d",&t); 
    while(t--)
    {
        long long m,n;
        long long ans;
        scanf("%lld%lld",&m,&n);
        if(n==0) ans=1;
        else ans=a[m]%MOD*b[n]%MOD*b[m-n]%MOD;
        printf("Case %d: ",Case++);
        printf("%lld\n",ans);   
    }
    return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值