POJ—3669 Meteor Shower(BFS)

Meteor Shower
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 22993 Accepted: 5978
Description

Bessie hears that an extraordinary meteor shower is coming; reports say that these meteors will crash into earth and destroy anything they hit. Anxious for her safety, she vows to find her way to a safe location (one that is never destroyed by a meteor) . She is currently grazing at the origin in the coordinate plane and wants to move to a new, safer location while avoiding being destroyed by meteors along her way.

The reports say that M meteors (1 ≤ M ≤ 50,000) will strike, with meteor i will striking point (Xi, Yi) (0 ≤ Xi ≤ 300; 0 ≤ Yi ≤ 300) at time Ti (0 ≤ Ti ≤ 1,000). Each meteor destroys the point that it strikes and also the four rectilinearly adjacent lattice points.

Bessie leaves the origin at time 0 and can travel in the first quadrant and parallel to the axes at the rate of one distance unit per second to any of the (often 4) adjacent rectilinear points that are not yet destroyed by a meteor. She cannot be located on a point at any time greater than or equal to the time it is destroyed).

Determine the minimum time it takes Bessie to get to a safe place.

Input

  • Line 1: A single integer: M
  • Lines 2..M+1: Line i+1 contains three space-separated integers: Xi, Yi, and Ti

Output

  • Line 1: The minimum time it takes Bessie to get to a safe place or -1 if it is impossible.

Sample Input

4
0 0 2
2 1 2
1 1 2
0 3 5
Sample Output

5
Source

USACO 2008 February Silver

#include<cstdio>
#include<iostream>
#include<queue>
#include<cstring>
#include<algorithm>
using namespace std;
const int MAX = 100000+10;
const int INF = 0x3fffffff;
using namespace std;

int map[330][330];
int flag[330][330];
int dir[4][2]={{1,0},{-1,0},{0,1},{0,-1}};  
int n;

struct point{
    int x;
    int y;
    int t;
};
bool operator < (const point &a,const point &b)  
{  
    return a.t>b.t;  
}   
bool cmp(point a, point b){
    return a.t>b.t;
}

int bfs(){
    priority_queue<point> Q;
    point p1;
    p1.x=0;
    p1.y=0;
    p1.t=0;//p1 为初始时在原点,时间为0;
    Q.push(p1);//把原点入队列
    flag[p1.x][p1.y]=1;
    while( !Q.empty() ){//当队列不为空时
        point temp=Q.top();
        Q.pop();
        if(map[temp.x][temp.y]==-1){//如果这个点在第一象限,且之前没来过,且以后也不会被砸到
            return temp.t;//成功找到目标点,输出时间。
        }
        for(int i=0; i<4; i++){
            int tx=temp.x+dir[i][0];
            int ty=temp.y+dir[i][1];
            int t=temp.t+1;//更新时间
            if( 0<=tx && 0<=ty &&!flag[tx][ty] && (map[tx][ty]==-1||map[tx][ty]>t)){//如果这个点在第一象限,之前没来过,目前没有损坏 
                point p2;
                p2.x=tx;
                p2.y=ty;
                p2.t=t;//记录这个点的坐标,和到达这个点的时间,
                if(!flag[p2.x][p2.y]) 
                    Q.push(p2);//入队列。
                flag[tx][ty]=1;
            }
        }
    }
    return -1;
}

int main(){
    while( scanf("%d", &n)!=EOF ){
        memset(map,-1,sizeof(map));
        memset(flag,0,sizeof(flag));
        int x,y,t;
        for(int i=0;i<n;++i)  
        {  
            scanf("%d%d%d",&x,&y,&t);  
            if(map[x][y]==-1)//落地点之前没有被砸过,就更新时间  
                map[x][y]=t;  
            else  //被砸过的话更新为靠前的时间 
                map[x][y]=min(map[x][y],t);  
            for(int j=0;j<4;++j)  {  //处理落地点周围的四个点 
                int nx=x+dir[j][0];  
                int ny=y+dir[j][1];  
                if(nx>=0&&ny>=0)  {  //同样的更新时间 
                    if(map[nx][ny]==-1)  
                        map[nx][ny]=t;  
                    else  
                        map[nx][ny]=min(t,map[nx][ny]);   
                }  
            }  
        }  
        int ans=bfs();
        if(ans!=-1) printf("%d\n",ans);
        else printf("-1\n");
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值