uva424(大数)

http://uva.onlinejudge.org/index.php?option=com_onlinejudge&Itemid=8&page=show_problem&problem=365

424 - Integer Inquiry

Time limit: 3.000 seconds


Integer Inquiry

One of the first users of BIT's new supercomputer was Chip Diller. He extended his exploration of powers of 3 to go from 0 to 333 and he explored taking various sums of those numbers.

``This supercomputer is great,'' remarked Chip. ``I only wish Timothy were here to see these results.'' (Chip moved to a new apartment, once one became available on the third floor of the Lemon Sky apartments on Third Street.)

Input

The input will consist of at most 100 lines of text, each of which contains a single VeryLongInteger. Each VeryLongInteger will be 100 or fewer characters in length, and will only contain digits (no VeryLongInteger will be negative).

The final input line will contain a single zero on a line by itself.

Output

Your program should output the sum of the VeryLongIntegers given in the input.

Sample Input

123456789012345678901234567890
123456789012345678901234567890
123456789012345678901234567890
0

Sample Output

370370367037037036703703703670
参考http://blog.csdn.net/huzhengnan/article/details/7076857的发现可以用白书73页的模版做。。原来一直不知道73页怎么用,原来是这样的。。谢谢最后的午餐了。。
#include <cstdio>   
#include <iostream> 
#include<cstring>
#include<string>
#include<algorithm>
using namespace std; 
#define MAXN 80 + 10 
#define MAX 255 + 10 
const int maxn = 1000; 
int max(int a,int b)
{
 return a>b?a:b;
}
// 大数类的定义  
struct bign 

    int len, s[maxn]; 
   bign() 
   
        memset(s, 0, sizeof(s)); 
       len = 1; 
   
     
    // 重载操作符‘=’用于赋值字符数组 
    bign operator = (const char* num) 
   
        len = strlen(num); 
        for(int i = 0; i < len; i++) 
       
            s[i] = num[len - i - 1] - '0'; 
       
        return *this; 
   
         
    // 重载操作符‘=’用于赋值数字  
    bign operator = (int num) 
   
       char s[maxn]; 
        sprintf(s, "%d", num); 
        *this = s; 
        return *this; 
   
     
    // 参数为数字类型的构造函数 
    bign(int num) 
   
        *this = num; 
    
     
    // 参数为字符数组类型的构造函数 
    bign(const char* num) 
   
        *this = num; 
    
     
    // 将字符数组转化成字符串 
    string str() const 
   
        string res = ""; 
       for(int i = 0; i < len; i++) 
       
            res = (char)(s[i] + '0') + res; 
       
        if(res == "") res = "0"; 
            return res; 
    
     
    // 重载操作符 + 
    bign operator + (const bign& b) const 
   
        bign c; 
        c.len = 0; 
        for(int i = 0, g = 0; g || i < max(len, b.len); i++) 
       
            int x = g; 
            if(i < len) 
                x += s[i]; 
            if(i < b.len) 
                x += b.s[i]; 
            c.s[c.len++] = x % 10; 
            g = x / 10; 
       
        return c; 
   
     
    // 重载操作符 +=  
    bign operator += (const bign& b) 
   
        *this = *this + b; 
        return *this; 
   
     
    // 重载比较操作符 < 
    bool operator < (const bign& b) const 
   
        if(len != b.len) return len < b.len; 
        for(int i = len - 1; i >= 0; i++) 
            if(s[i] != b.s[i]) 
               return s[i] < b.s[i]; 
        return false; 
   
     
    // 重载比较操作符 > 
    bool operator > (const bign& b) const 
   
        return b < *this; 
  
     
    // 重载比较操作符 <= 
    bool operator <= (const bign& b) const 
   
       return !(b < *this); 
   
     
    // 重载比较操作符 >= 
    bool operator >= (const bign& b) const 
   
        return !(*this < b); 
   
     
    // 重载比较操作符 != 
    bool operator != (const bign& b) const 
   
        return b < *this || *this < b; 
   
     
    // 重载比较操作符 == 
    bool operator == (const bign& b) const 
   
        return !(b < *this) && !(*this < b); 
   
}; 
 
    // 重载操作符 >> 
istream& operator >> (istream &in, bign& x) 

    string s; 
   in >> s; 
    x = s.c_str(); 
    return in;  
 
     
// 重载操作符 << 
ostream& operator << (ostream &out, const bign& x) 

    out << x.str(); 
   return out; 
 
 
int main() 
  
   //freopen("input.txt", "r", stdin); 
    //freopen("output.txt", "w", stdout); 
   bign num = 0; 
    bign result = 0; 
    while(cin >> num && num != 0) 
   
        result += num;
    }
   cout << result << endl; 
    return 0; 

这题还可以用到杭电1002上
#include <cstdio>   
#include <iostream> 
#include<cstring>
#include<string>
#include<algorithm>
using namespace std; 
#define MAXN 80 + 10 
#define MAX 255 + 10 
const int maxn = 1000; 
int max(int a,int b)
{
 return a>b?a:b;
}
// 大数类的定义  
struct bign 

    int len, s[maxn]; 
   bign() 
   
        memset(s, 0, sizeof(s)); 
       len = 1; 
   
     
    // 重载操作符‘=’用于赋值字符数组 
    bign operator = (const char* num) 
   
        len = strlen(num); 
        for(int i = 0; i < len; i++) 
       
            s[i] = num[len - i - 1] - '0'; 
       
        return *this; 
   
         
    // 重载操作符‘=’用于赋值数字  
    bign operator = (int num) 
   
       char s[maxn]; 
        sprintf(s, "%d", num); 
        *this = s; 
        return *this; 
   
     
    // 参数为数字类型的构造函数 
    bign(int num) 
   
        *this = num; 
    
     
    // 参数为字符数组类型的构造函数 
    bign(const char* num) 
   
        *this = num; 
    
     
    // 将字符数组转化成字符串 
    string str() const 
   
        string res = ""; 
       for(int i = 0; i < len; i++) 
       
            res = (char)(s[i] + '0') + res; 
       
        if(res == "") res = "0"; 
            return res; 
    
     
    // 重载操作符 + 
    bign operator + (const bign& b) const 
   
        bign c; 
        c.len = 0; 
        for(int i = 0, g = 0; g || i < max(len, b.len); i++) 
       
            int x = g; 
            if(i < len) 
                x += s[i]; 
            if(i < b.len) 
                x += b.s[i]; 
            c.s[c.len++] = x % 10; 
            g = x / 10; 
       
        return c; 
   
     
    // 重载操作符 +=  
    bign operator += (const bign& b) 
   
        *this = *this + b; 
        return *this; 
   
     
    // 重载比较操作符 < 
    bool operator < (const bign& b) const 
   
        if(len != b.len) return len < b.len; 
        for(int i = len - 1; i >= 0; i++) 
            if(s[i] != b.s[i]) 
               return s[i] < b.s[i]; 
        return false; 
   
     
    // 重载比较操作符 > 
    bool operator > (const bign& b) const 
   
        return b < *this; 
  
     
    // 重载比较操作符 <= 
    bool operator <= (const bign& b) const 
   
       return !(b < *this); 
   
     
    // 重载比较操作符 >= 
    bool operator >= (const bign& b) const 
   
        return !(*this < b); 
   
     
    // 重载比较操作符 != 
    bool operator != (const bign& b) const 
   
        return b < *this || *this < b; 
   
     
    // 重载比较操作符 == 
    bool operator == (const bign& b) const 
   
        return !(b < *this) && !(*this < b); 
   
}; 
 
    // 重载操作符 >> 
istream& operator >> (istream &in, bign& x) 

    string s; 
   in >> s; 
    x = s.c_str(); 
    return in;  
 
     
// 重载操作符 << 
ostream& operator << (ostream &out, const bign& x) 

    out << x.str(); 
   return out; 
 
 
int main() 
  
   //freopen("input.txt", "r", stdin); 
    //freopen("output.txt", "w", stdout); 
   bign num1 = 0,num2=0; 
    bign result = 0; 
   
   //cout << result << endl; 
 int t;
 scanf("%d",&t);
 int count=0;
 while(t--)
 {
  cin>>num1>>num2;
  printf("Case %d:\n",++count);
  cout<<num1;
  printf(" + ");
  cout<<num2;
  printf(" = ");
  cout<<num1+num2<<endl;
  if(t)
   printf("\n");
 }
    return 0; 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值