The "Hamilton cycle problem" is to find a simple cycle that contains every vertex in a graph. Such a cycle is called a "Hamiltonian cycle".
In this problem, you are supposed to tell if a given cycle is a Hamiltonian cycle.
Input Specification:
Each input file contains one test case. For each case, the first line contains 2 positive integers N (2<N≤200), the number of vertices, and M, the number of edges in an undirected graph. Then M lines follow, each describes an edge in the format Vertex1 Vertex2
, where the vertices are numbered from 1 to N. The next line gives a positive integer K which is the number of queries, followed by K lines of queries, each in the format:
n V1 V2 ... Vn
where n is the number of vertices in the list, and Vi's are the vertices on a path.
Output Specification:
For each query, print in a line YES
if the path does form a Hamiltonian cycle, or NO
if not.
Sample Input:
6 10
6 2
3 4
1 5
2 5
3 1
4 1
1 6
6 3
1 2
4 5
6
7 5 1 4 3 6 2 5
6 5 1 4 3 6 2
9 6 2 1 6 3 4 5 2 6
4 1 2 5 1
7 6 1 3 4 5 2 6
7 6 1 2 5 4 3 1
Sample Output:
YES
NO
NO
NO
YES
NO
#include <bits/stdc++.h>
using namespace std;
int n,v,e,graph[300][300],a,b;
int main(){
scanf("%d %d",&v,&e);
for(int i=0;i<e;i++){
scanf("%d %d",&a,&b);
graph[a][b]=graph[b][a]=1;
}
scanf("%d",&n);
for(int i=0;i<n;i++){
int t,last=-1,temp,f[300]={0},bf=1,start=-1;
scanf("%d",&t);
for(int j=0;j<t;j++){
scanf("%d",&temp);
if(!bf)continue;
if(j==0)start=temp; //记录d开始元素
if(f[temp]==0)f[temp]=1;
else if(j!=t-1&&f[temp])bf=0; //(1)中间数字出现多次
if(last!=-1&&!graph[temp][last])bf=0; // (3)如果不联通,排除
last=temp;
}
if(start!=temp)bf=0; //(2)检验是否成环
for(int j=1;j<=v;j++)
if(!f[j]){bf=0;break;} //(1)检验未包含所有点
if(bf)printf("YES\n");
else printf("NO\n");
}
return 0;
}