1127 ZigZagging on a Tree

Suppose that all the keys in a binary tree are distinct positive integers. A unique binary tree can be determined by a given pair of postorder and inorder traversal sequences. And it is a simple standard routine to print the numbers in level-order. However, if you think the problem is too simple, then you are too naive. This time you are supposed to print the numbers in "zigzagging order" -- that is, starting from the root, print the numbers level-by-level, alternating between left to right and right to left. For example, for the following tree you must output: 1 11 5 8 17 12 20 15.

zigzag.jpg

Input Specification:

Each input file contains one test case. For each case, the first line gives a positive integer N (≤30), the total number of nodes in the binary tree. The second line gives the inorder sequence and the third line gives the postorder sequence. All the numbers in a line are separated by a space.

Output Specification:

For each test case, print the zigzagging sequence of the tree in a line. All the numbers in a line must be separated by exactly one space, and there must be no extra space at the end of the line.

Sample Input:

8
12 11 20 17 1 15 8 5
12 20 17 11 15 8 5 1

Sample Output:

1 11 5 8 17 12 20 15

 

#include <bits/stdc++.h>

using namespace std;
int n,inorder[40],poster[40],tree[100000],level[40],lc[40],mm=0,j=1;
queue<int>que;
void build(int inl,int inr,int pol,int por,int root){
    if(inl>inr)return;
    tree[root]=poster[por];
    if(inl==inr)return;
    int it=inl;
    for(;it<=inr&&inorder[it]!=poster[por];it++);       //找到根
    build(inl, it-1, pol, pol+it-inl-1, root*2);
    build(it+1, inr,pol+it-inl , por-1, root*2+1);
}
void level_traverse(){
    que.push(1);
    int cnt=0;
    while (!que.empty()) {
        int it = que.front();
        que.pop();
        level[cnt++]=tree[it];
        if(tree[it*2]>0)que.push(it*2);
        if(tree[2*it+1]>0)que.push(it*2+1);
    }
}
void dfs(int i,int c){
    lc[c]++;
    if(c>mm)mm=c;
    if(tree[i*2]>0)dfs(i*2, c+1);
    if(tree[i*2+1]>0)dfs(i*2+1, c+1);
}

int main(){
    //std::ios::sync_with_stdio(false);
    scanf("%d",&n);
    for(int i=0;i<n;i++)scanf("%d",&inorder[i]);
    for(int i=0;i<n;i++)scanf("%d",&poster[i]);
    build(0, n-1, 0, n-1, 1);
    level_traverse();
    dfs(1, 1);
    printf("%d",level[0]);
    for(int i=2;i<=mm;i++){
        vector<int>temp;
        for(int k=0;k<lc[i];k++,j++)
            temp.push_back(level[j]);
        if(i%2) reverse(temp.begin(), temp.end());  //奇数层层序反转
        for(int k=0;k<temp.size();k++)
            printf(" %d",temp[k]);
    }
    
    return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值