1127 ZigZagging on a Tree (30分)——C/C++

1127 ZigZagging on a Tree (30分)

Suppose that all the keys in a binary tree are distinct positive integers. A unique binary tree can be determined by a given pair of postorder and inorder traversal sequences. And it is a simple standard routine to print the numbers in level-order. However, if you think the problem is too simple, then you are too naive. This time you are supposed to print the numbers in “zigzagging order” – that is, starting from the root, print the numbers level-by-level, alternating between left to right and right to left. For example, for the following tree you must output: 1 11 5 8 17 12 20 15.
在这里插入图片描述

Input Specification:

Each input file contains one test case. For each case, the first line gives a positive integer N (≤30), the total number of nodes in the binary tree. The second line gives the inorder sequence and the third line gives the postorder sequence. All the numbers in a line are separated by a space.

Output Specification:

For each test case, print the zigzagging sequence of the tree in a line. All the numbers in a line must be separated by exactly one space, and there must be no extra space at the end of the line.

Sample Input:

8
12 11 20 17 1 15 8 5
12 20 17 11 15 8 5 1

Sample Output:

1 11 5 8 17 12 20 15

题目大意及分析:

该题是给出中序和后序,建树,然后按一条龙似的输出结点。这种题的大致思路都是递归遍历。在遍历过程中找到结点所在的层数level。root为根结点在后序中的下标,start与end为中序中最左边与最右边的结点下标。数组v[ ]存储排序后的数据,这里我是用的初始化数组v[ ],应该也可以动态分配内存。

代码:

#include<stdio.h>
#include<algorithm>
using namespace std;
#define max 9999

typedef struct Node{
	int id;
	int index;
	int level;
}node;
node v[35];

int in[35];
int post[35];
int j=0;

void PreOrder(int root,int start,int end,int index,int level){
	if(start>end)
		return;
	int i=start;
	while(start<=end && post[root]!=in[i])
		i++;
	v[j].id=post[root];
	v[j].index=index;
	v[j++].level=level;
	PreOrder(root-1-(end-i),start,i-1,2*index+1,level+1);
	PreOrder(root-1,i+1,end,2*index+2,level+1);
}

bool compare(node x,node y){
	if(x.level!=y.level)
		return x.level < y.level;
	if(x.level%2==0)
		return x.index > y.index;
	return x.index < y.index;
}
int main(){
	int n,i;
	scanf("%d",&n);
	for(i=0;i<n;i++){
		scanf("%d",&in[i]);
	}
	for(i=0;i<n;i++){
		scanf("%d",&post[i]);
	}
	for(i=0;i<35;i++){
		v[i].id=v[i].index=v[i].level=max;
	}
	PreOrder(n-1,0,n-1,0,0);
	sort(v,v+35,compare);
	for(i=0;i<n;i++){
		printf("%d",v[i].id);
		if(i<n-1)
			printf(" ");
	}
	return 0;
}
  • 0
    点赞
  • 5
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

21岁被迫秃头

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值