1040 Longest Symmetric String (Manacher算法)

1040 Longest Symmetric String (25 分)

Given a string, you are supposed to output the length of the longest symmetric sub-string. For example, given Is PAT&TAP symmetric?, the longest symmetric sub-string is s PAT&TAP s, hence you must output 11.

Input Specification:

Each input file contains one test case which gives a non-empty string of length no more than 1000.

Output Specification:

For each test case, simply print the maximum length in a line.

Sample Input:

Is PAT&TAP symmetric?

Sample Output:

11
#include<bits/stdc++.h>
using namespace std;

char  s[3000],c;
int  sj = 0, p[3000] = { 0 },mx=0,id,len=1;
int main() {
	s[sj++] = '\n';
	while (scanf("%c",&c)!=EOF) {
		s[sj++] = c;
		s[sj++] = '\n';          //s的首尾字符要一致,不然偶数串错误
	}
	s[sj]  = '\0';
	for (int i = 1; i < sj; i++) {
		if (i < mx) p[i] = min(p[id * 2 - i], mx - id);
		else p[i] = 1;
		while (s[i - p[i]] == s[i + p[i]])++p[i];
		if (p[id] < p[i]) {
			id = i;
			mx = p[i] + i;
		}
		len = max(len, p[i] - 1);
	}
	cout << len;
	return 0;
}	

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值