HDU5478 Can you find it 数学快速幂

http://acm.hdu.edu.cn/showproblem.php?pid=5478

枚举a,b=第一个式子中所得数,验证即可。

Problem Description

Given a prime number C(1≤C≤2×105) , and three integers k1, b1, k2 (1≤k1,k2,b1≤109) . Please find all pairs (a, b) which satisfied the equation ak1⋅n+b1 + bk2⋅n−k2+1 = 0 (mod C)(n = 1, 2, 3, ...).

 

 

Input

There are multiple test cases (no more than 30). For each test, a single line contains four integers C, k1, b1, k2.

 

 

Output

First, please output "Case #k: ", k is the number of test case. See sample output for more detail.
Please output all pairs (a, b) in lexicographical order. (1≤a,b<C) . If there is not a pair (a, b), please output -1.

 

 

Sample Input

 

23 1 1 2

 

 

Sample Output

 

Case #1: 1 22

 

 

Source

2015 ACM/ICPC Asia Regional Shanghai Online

 

#include<iostream>
#include<cstdio>
#include<cstring>
 
using namespace std;
 
typedef long long LL;
 
LL pow_mod(LL a,LL n,LL m)
{
    if(n==0)
        return 1;
    LL x=pow_mod(a,n/2,m);
    LL ans = x*x%m;
    if(n%2==1)ans=ans*a%m;
    return ans;
}
 
int main()
{
    //freopen("input.txt","r",stdin);
    int time=0;
    LL c, k1, k2, b1;
    while(scanf("%lld%lld%lld%lld",&c,&k1,&b1,&k2)!=EOF)
    {
        time++;
        printf("Case #%d:\n",time);
        bool flag=0;
        for(LL i=1;i<c;i++)
        {
            LL left=pow_mod(i,k1,c);
            LL b=c-pow_mod(i,k1+b1,c);
            LL right=pow_mod(b,k2,c);
            if(left==right)
            {
                flag=1;
                printf("%lld %lld\n",i,b);
            }
        }
        if(!flag)
            printf("-1\n");
    }
    return 0;
}

 

评论 2
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值