拓扑排序例题

Windy has N balls of distinct weights from 1 unit to N units. Now he tries to label them with 1 to N in such a way that:

  1. No two balls share the same label.
  2. The labeling satisfies several constrains like "The ball labeled with a is lighter than the one labeled with b".

Can you help windy to find a solution?

Input

The first line of input is the number of test case. The first line of each test case contains two integers, N (1 ≤ N ≤ 200) and M (0 ≤ M ≤ 40,000). The next M line each contain two integers a and b indicating the ball labeled with a must be lighter than the one labeled with b. (1 ≤ a, b ≤ N) There is a blank line before each test case.

Output

For each test case output on a single line the balls' weights from label 1 to label N. If several solutions exist, you should output the one with the smallest weight for label 1, then with the smallest weight for label 2, then with the smallest weight for label 3 and so on... If no solution exists, output -1 instead.

Sample Input

5

4 0

4 1
1 1

4 2
1 2
2 1

4 1
2 1

4 1
3 2

Sample Output

1 2 3 4
-1
-1
2 1 3 4
1 3 2 4

就是说给你一个t 然后给出n,m n 个数,m个数据联系 a  b表示a比b轻。

怎么会想到拓扑排序呢?

因为要选出重量对吧,如果我们构成一个有向无环图,大的重量的点指向小的重量的点,根据题给定数据构建一个图

然后不断取出入度为0的点,这里如果同时出现多个入度为0的点,先选数(这个点标号)比较大的

为什么要选数大的呢?因为题中要求了输出的第一个值要比较小.....(在有可能多组答案前提下)

若拓扑排序得到的序号是 2 4 3 5 1(节点标号),再与5 4 3 2 1(数值)一一对应,得到ans[2] = 5, ans[4] = 4, ans[3] = 3, ans[5] = 2, ans[1] = 1 ,假设这里选标号 3 4 的时候他俩入度同时为0,如果先选3的话,那么与后面的数值对应的时候,ans[3]就比较大了,所以这样做可以保证符合题意。

#include <queue>
#include <cstdio>
#include <vector>
#include <cstring>
#include <algorithm>
#include <functional>
using namespace std;

const int maxn = 200 + 66;

int res[maxn];
int n, m, in[maxn];
int vis[maxn][maxn];
vector<int> ans, vec[maxn];

bool toposort()
{
    int p, v, len;

    priority_queue<int> q;
    while(!q.empty())
        q.pop();
    for(int i = 1; i <= n; ++i)
    {
        if(!in[i])
            q.push(i);
    }

    while(!q.empty())
    {
        p = q.top();
        ans.push_back(p);
        q.pop();

        len = vec[p].size();
        for(int i = 0; i < len; ++i)
        {
            v = vec[p][i];//
            --in[v];
            if(!in[v])
                q.push(v);
        }
    }

    if(ans.size() == n)
        return true;
    else
        return false;
}
int main()
{
    int t, a, b;
    scanf("%d", &t);
    while(t--)
    {
        scanf("%d%d", &n, &m);

        memset(in, 0, sizeof(in));
        memset(vis, 0, sizeof(vis));
        for(int i = 0; i <= n; ++i)
            vec[i].clear();

        for(int i = 0; i < m; ++i)
        {
            scanf("%d%d", &a, &b);
            if(!vis[b][a])
            {
                vec[b].push_back(a);//b重
                vis[b][a] = 1;
                ++in[a];//
            }
        }

        ans.clear();
        if(toposort())
        {
            int len = ans.size();
            for(int i = 0, j = n; i < len; ++i, --j)
            {
                res[ans[i]] = j;
            }
            for(int i = 1; i <= n; ++i)
            {
                printf("%d%c", res[i], (i == n ? '\n' : ' '));
            }
        }
        else
            puts("-1");
    }
    return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值