Party All the Time(三分)

In the Dark forest, there is a Fairy kingdom where all the spirits will go together and Celebrate the harvest every year. But there is one thing you may not know that they hate walking so much that they would prefer to stay at home if they need to walk a long way.According to our observation,a spirit weighing W will increase its unhappyness for S 3*W units if it walks a distance of S kilometers. 
Now give you every spirit's weight and location,find the best place to celebrate the harvest which make the sum of unhappyness of every spirit the least.

Input

The first line of the input is the number T(T<=20), which is the number of cases followed. The first line of each case consists of one integer N(1<=N<=50000), indicating the number of spirits. Then comes N lines in the order that x [i]<=x [i+1]for all i(1<=i<N). The i-th line contains two real number : X i,W i, representing the location and the weight of the i-th spirit. ( |x i|<=10 6, 0<w i<15 )

Output

For each test case, please output a line which is "Case #X: Y", X means the number of the test case and Y means the minimum sum of unhappyness which is rounded to the nearest integer.

Sample Input

1
4
0.6 5
3.9 10
5.1 7
8.4 10

Sample Output

Case #1: 832

基本是三分模板题(注意w也是浮点数)

代码:

#include<cstdio>
#include<iostream>
#include<algorithm>
#include<cstring>
#include<map>
#include<set>
#include<stack>
#include<queue>
#include<vector>
#include<cmath>

const int maxn=1e5+5;
typedef long long ll;
using namespace std;
struct node
{
	double s;
	double w;
}p[maxn];
int n;
double fun(double x)
{
	double sum=0;
	for(int t=0;t<n;t++)
	{
	double ss;
	ss=fabs(p[t].s-x);
	sum+=ss*ss*ss*p[t].w;	
	}
	return sum;
}  
int main()
{
	int T;
	cin>>T;
	for(int t=0;t<T;t++)
	{
		scanf("%d",&n);
		for(int j=0;j<n;j++)
		{
			scanf("%lf%lf",&p[j].s,&p[j].w);
		}
		double l=p[0].s,r=p[n-1].s;
		double m1,m2;
		while(r-l>1e-6)
		{
			
			m1=(l+r)/2;
			m2=(m1+r)/2;
			if(fun(m1)>fun(m2)+1e-6)
			{
				l=m1;
			}
			else
			{
				r=m2;
			}
		}
		int sss=fun(l)+0.5;
		cout<<"Case #"<<t+1<<": "<<sss<<endl;
	}
	
	return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

black-hole6

你的鼓励将是我创作的动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值