PAT 1059. Prime Factors (25)

题目描述
Given any positive integer N, you are supposed to find all of its prime factors, and write them in the format N = p1^k1 * p2^k2 *…*pm^km.

Input Specification:

Each input file contains one test case which gives a positive integer N in the range of long int.

Output Specification:

Factor N in the format N = p1^k1 * p2^k2 *…*pm^km, where pi’s are prime factors of N in increasing order, and the exponent ki is the number of pi – hence when there is only one pi, ki is 1 and must NOT be printed out.

Sample Input:
97532468
Sample Output:
97532468=2^2*11*17*101*1291

代码如下:

#include <iostream>
using namespace std;

typedef long long LL;

bool isPrime(LL n) {

    for(LL i = 2; i * i <= n; i ++) {
        if(n % i == 0)
            return false;
    }
    return true;
}

int main()
{
    LL n;
    cin >> n;
    LL t = n, k;
    int flag = 1;
    if(isPrime(n)) {
        cout << n << "=" << n << endl;
    }
    else {
        cout << n << "=";
        for(int i = 2; i * i <= n; i ++) {
            if(isPrime(i)) {
                k = 0;
                while(t % i == 0) {
                    k ++;
                    t /= i;
                }
                if(k == 1) {
                    if(flag) {
                        cout << i;
                        flag = 0;
                    }
                    else {
                        cout << "*" << i;
                    }
                } else if(k >= 2) {
                    if(flag) {
                        cout << i << "^" << k;
                        flag = 0;
                    } else {
                        cout << "*" << i << "^" << k;
                    }
                }
            }
        }
        cout << endl;
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值