POJ 3041 - Asteroids

A - Asteroids
Time Limit:1000MS     Memory Limit:65536KB     64bit IO Format:%I64d & %I64u
Appoint description: 

Description

Bessie wants to navigate her spaceship through a dangerous asteroid field in the shape of an N x N grid (1 <= N <= 500). The grid contains K asteroids (1 <= K <= 10,000), which are conveniently located at the lattice points of the grid. 

Fortunately, Bessie has a powerful weapon that can vaporize all the asteroids in any given row or column of the grid with a single shot.This weapon is quite expensive, so she wishes to use it sparingly.Given the location of all the asteroids in the field, find the minimum number of shots Bessie needs to fire to eliminate all of the asteroids.

Input

* Line 1: Two integers N and K, separated by a single space. 
* Lines 2..K+1: Each line contains two space-separated integers R and C (1 <= R, C <= N) denoting the row and column coordinates of an asteroid, respectively.

Output

* Line 1: The integer representing the minimum number of times Bessie must shoot.

Sample Input

3 4
1 1
1 3
2 2
3 2

Sample Output

2

Hint

INPUT DETAILS: 
The following diagram represents the data, where "X" is an asteroid and "." is empty space: 
X.X 
.X. 
.X.


OUTPUT DETAILS: 
Bessie may fire across row 1 to destroy the asteroids at (1,1) and (1,3), and then she may fire down column 2 to destroy the asteroids at (2,2) and (3,2).

匈牙利算法模板题,每次武器能处理一行或一列,把行集合看成集合1,列集合看成集合2,X点为集合1到集合2的边,从而建图。题目转化成求二分图的最小点覆盖

另外转载一些总结:

1、一个二分图中的最大匹配数等于这个图中的最小点覆盖数

2、最小路径覆盖=最小路径覆盖=|G|-最大匹配数

3、二分图最大独立集=顶点数-二分图最大匹配



#include <iostream>
#include <cstdio>
#include <cstring>
#include <algorithm>
using namespace std;

#define N 505

int n,k;
int g[N][N];
int vis[N];
int last[N];

bool find(int u){
	for (int v=0;v<n;v++){
		if (g[u][v] && !vis[v]){
			vis[v]=1;
			if (last[v]==-1 || find(last[v])){
				last[v]=u;
				return true;
			}
		}
	}
	return false;
}

int hungary(){
	int ret=0;
	for (int i=0;i<n;i++){
		memset(vis,0,sizeof(vis));
		if (find(i))
			ret++;
	}
	return ret;
}

int main(){
	while (scanf("%d%d",&n,&k)!=EOF){
		memset(last,-1,sizeof(last));
		memset(g,0,sizeof(g));
		for (int i=0;i<k;i++){
			int x,y;
			scanf("%d%d",&x,&y);
			g[x-1][y-1]=1;
		}
		printf("%d\n",hungary());
	}

	return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值