杭电 1196 Lowest Bit

Problem Description
Given an positive integer A (1 <= A <= 100), output the lowest bit of A.

For example, given A = 26, we can write A in binary form as 11010, so the lowest bit of A is 10, so the output should be 2.

Another example goes like this: given A = 88, we can write A in binary form as 1011000, so the lowest bit of A is 1000, so the output should be 8.

Input
Each line of input contains only an integer A (1 <= A <= 100). A line containing “0” indicates the end of input, and this line is not a part of the input data.

Output
For each A in the input, output a line containing only its lowest bit.

Sample Input
26
88
0

Sample Output
2
8

这道题理解题意就好,但最后出现了一些小bug QAQ~最后的输出必须写成printf("%d\n",(int)pow(2,i));这种形式才可以输出正确结果,如果写成printf("%d\n",pow(2,i));就只能输出0了。这是因为pow函数结果是double类型的,而输出却用%d输出,并且printf函数不会进行类型转化,所以就会出错,写下了算是给自己以后一个教训叭**

#include<iostream>
#include<math.h>
#include<cmath>
#include<stdio.h>
#include<algorithm>
using namespace std;
int main()
{
   int n,i;
   int s[10];
   while(scanf("%d",&n)!=EOF)
   {
        if(n==0)
		break;
		for(i=0;i<10;i++)
		{
		    if(n%2==0)
		    {
		   	   s[i]=0;
			}	
		   
		   else
		   {
		   	s[i]=1;
		   	break;
		   }
		   n/=2;
	    }
		//printf("%d\n",pow(2,i));
   printf("%d\n",(int)pow(2,i));
   }
   return 0;	
} 

~

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值