【PAT甲级】 1008 Elevator

【PAT甲级】 1008 Elevator

原题

The highest building in our city has only one elevator. A request list is made up with N positive numbers. The numbers denote at which floors the elevator will stop, in specified order. It costs 6 seconds to move the elevator up one floor, and 4 seconds to move down one floor. The elevator will stay for 5 seconds at each stop.

For a given request list, you are to compute the total time spent to fulfill the requests on the list. The elevator is on the 0th floor at the beginning and does not have to return to the ground floor when the requests are fulfilled.

Input Specification:

Each input file contains one test case. Each case contains a positive integer N, followed by N positive numbers. All the numbers in the input are less than 100.

Output Specification:

For each test case, print the total time on a single line.

Sample Input 1:

    3 2 3 1

Sample Output 1:

    41

思路

题目要求

电梯上行一层需要6秒,下行一层需要4秒,停顿时间为5秒;给定一组整数序列,求满足该序列(按照该序列的顺序)电梯所要花费的总时间。

题目分析

  1. 按照顺序判断上升还是下落;
  2. 按照上升或下落的秒数进行加减即可;
  3. 第一个数字不是楼层数,不然算出来应该是54;

易错点

  1. 从0层开始;
  2. cin的话ctrl+z就会显示结果,但是scanf需要输入的不为整数,比如a才会退出;

参考代码如下

#include <iostream>
#include <vector>
using namespace std;
int main(){
	int begin=0,end;//刚开始为0层
	int sum=0;
	scanf("%d",&end);//第一个数可以不用,如果用的话就下面用for循环即可
	while(cin>>end){//用scanf会运行超时
		if(begin-end >= 0){
			sum=sum+4*(begin-end)+5;
		}
		else{
			sum=sum-6*(begin-end)+5;
		}
		begin=end;
	}
	printf("%d",sum);
}

  • 网上的参考代码很多;
  • 以上仅是用来记录我个人的想法和答题方式;
  • 仅为入门选手,如有错误或者更好的方法欢迎指正与探讨;
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值