【PAT甲级】 1015 Reversible Primes

【PAT甲级】 1015 Reversible Primes

原题

A reversible prime in any number system is a prime whose “reverse” in that number system is also a prime. For example in the decimal system 73 is a reversible prime because its reverse 37 is also a prime.

Now given any two positive integers N (<105) and D (1<D≤10), you are supposed to tell if N is a reversible prime with radix D.

Input Specification:

The input file consists of several test cases. Each case occupies a line which contains two integers N and D. The input is finished by a negative N.

Output Specification:

For each test case, print in one line Yes if N is a reversible prime with radix D, or No if not.

Sample Input:

73 10
23 2
23 10
-2

Sample Output:

Yes
Yes
No

思路

题目要求

给定一个素数及他的进制,求该素数在给定进制下是否为可逆素数(即倒转过来依旧是素数);输入为负数就终止

题目分析

  1. 求逆的时候要记得按对应的进制去求;
  2. 依据题意,并没有说给定的数一定是素数,故也要进行判断;

参考代码如下

#include <iostream>
#include <cmath>
using namespace std;
bool isPrime(int num){
	if(num==0 || num==1 || num==3){
		return false;
	}
	if(num==2 || num==3){
		return true;
	}
	for(int i=2;i<=sqrt(num);i++){
		if(num%i==0)
			return false;
	}
	return true;
}
int main() {
	int n,d;
	while(scanf("%d",&n)){
		if(n<0)
			break;
		scanf("%d",&d);
		if(!isPrime(n)){//先判断再转换,万一本身就不是素数可以减少时间
			printf("No\n");
            continue;
		}
		int num=0,m=n%d;
		n/=d;
		while(n){
			m=m*d+n%d;
			n/=d;
		}
        printf("%s", isPrime(m) ? "Yes\n" : "No\n");
	}
}
    

  • 网上的参考代码很多;
  • 以上仅是用来记录我个人的想法和答题方式;
  • 仅为入门选手,如有错误或者更好的方法欢迎指正与探讨;
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值