【PAT甲级】 1002 A+B for Polynomials

【PAT甲级】 1002 A+B for Polynomials

原题

This time, you are supposed to find A+B where A and B are two polynomials.

Input Specification:

Each input file contains one test case. Each case occupies 2 lines, and each line contains the information of a polynomial:

K N1 aN1 N2 aN2 … NK aNK

where K is the number of nonzero terms in the polynomial, Niand aNi(i=1,2,⋯,K) are the exponents and coefficients, respectively. It is given that 1≤K≤10,0≤NK<⋯<N2<N1≤1000.

Output Specification:

For each test case you should output the sum of A and B in one line, with the same format as the input. Notice that there must be NO extra space at the end of each line. Please be accurate to 1 decimal place.

Sample Input 1:

2 1 2.4 0 3.2
2 2 1.5 1 0.5

Sample Output 1:

3 2 1.5 1 2.9 0 3.2

思路

题目要求

多项式相加,给出两行,第一个数为多项式中非零项的个数,后面依次给出指数和系数。

题目分析

  1. 精确到一位小数;
  2. 输出为一行;
  3. 指数本身为整数输出不需要带.0
  4. 这类题目基本上的第一想法就是空间换时间;
  5. 上面的题目可以看成是:
    2.4x1 + 3.2x0
    1.5x2 + 0.5x1

参考代码如下

#include <stdio.h>
#include <string.h> //memset头文件
#define N 1001 //不能用typedef 1000 N啊

int main(){
	float n[N];
	memset(n,(int)0.0,N*sizeof(float));//我也不确定这个和直接for赋值哪个快
	int m,i;
	float k;
	scanf("%d",&m);
	while(m--){
		scanf("%d %f",&i,&k);
		n[i]+=k;
	}
	scanf("%d",&m);
	while(m--){
		scanf("%d %f",&i,&k);
		n[i]+=k;
	}
	int num=0;
	for(i=0;i<N;i++){
		if(n[i]!=0) num++;
	}
	printf("%d",num);
	for(i=N-1;i>=0;i--){
		if(n[i]!=0){
			printf(" %d %0.1f",i,n[i]);//有输出的中间要空格
		}
	}
}

  • 网上的参考代码很多;
  • 以上仅是用来记录我个人的想法和答题方式;
  • 仅为入门选手,如有错误或者更好的方法欢迎指正与探讨;
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值