【PAT甲级】 1014 Waiting in Line

【PAT甲级】 1014 Waiting in Line

原题

Suppose a bank has N windows open for service. There is a yellow line in front of the windows which devides the waiting area into two parts. The rules for the customers to wait in line are:

  • The space inside the yellow line in front of each window is enough to contain a line with M customers. Hence when all the N lines are full, all the customers after (and including) the (NM+1)st one will have to wait in a line behind the yellow line.
  • Each customer will choose the shortest line to wait in when crossing the yellow line. If there are two or more lines with the same length, the customer will always choose the window with the smallest number.
  • Customeri will take Ti minutes to have his/her transaction processed.
  • The first N customers are assumed to be served at 8:00am.

Now given the processing time of each customer, you are supposed to tell the exact time at which a customer has his/her business done.

For example, suppose that a bank has 2 windows and each window may have 2 customers waiting inside the yellow line. There are 5 customers waiting with transactions taking 1, 2, 6, 4 and 3 minutes, respectively. At 08:00 in the morning, customer1 is served at window1 while customer2 is served at window2. customer3 will wait in front of window1 and customer4 will wait in front of window2. customer5 will wait behind the yellow line.

At 08:01, customer1 is done and customer5 enters the line in front of window1 since that line seems shorter now. customer2 will leave at 08:02, customer4 at 08:06, customer3 at 08:07, and finally customer5 at 08:10.

Input Specification:

Each input file contains one test case. Each case starts with a line containing 4 positive integers: N (≤20, number of windows), M (≤10, the maximum capacity of each line inside the yellow line), K (≤1000, number of customers), and Q (≤1000, number of customer queries).

The next line contains K positive integers, which are the processing time of the K customers.

The last line contains Q positive integers, which represent the customers who are asking about the time they can have their transactions done. The customers are numbered from 1 to K.Each input file contains one test case. Each case starts with a line containing 3 numbers N (<1000), M and K, which are the total number of cities, the number of remaining highways, and the number of cities to be checked, respectively. Then M lines follow, each describes a highway by 2 integers, which are the numbers of the cities the highway connects. The cities are numbered from 1 to N. Finally there is a line containing K numbers, which represent the cities we concern.

Output Specification:

For each of the Q customers, print in one line the time at which his/her transaction is finished, in the format HH:MM where HH is in [08, 17] and MM is in [00, 59]. Note that since the bank is closed everyday after 17:00, for those customers who cannot be served before 17:00, you must output Sorry instead.

Sample Input:

2 2 7 5
1 2 6 4 3 534 2
3 4 5 6 7

Sample Output:

08:07
08:06
08:10
17:00
Sorry

思路

题目要求

给定窗口数,可排队人数,顾客数;给出每位顾客的处理时间,服务的开始时间和结束时间;要求选择排队人数最少的窗口进入(相等时选择编号小的);求给出的第t个人服务结束的时间。

题目分析

  1. 首先考虑到每个窗口都是一个队列,队列最大长度为每个窗口的可排队人数;
  2. 设立窗口结构体,包括队列中的第一个人服务完成时间,最后一个人的服务结束时间,排队队列;
  3. 对于不在黄线内的人,根据各个窗口第一个人的服务完成时间依次入队;此时若最后一个人的服务结束时间超过17点就标记为Sorry;

易错点

  1. 不是说客户服务结束时间超过17:00就输出Sorry;
  2. 如果一个客户在17:00以及以后还没有开始服务输出sorry;
  3. 如果这个服务已经开始了,无论时间多长都要等他服务完毕;

参考代码如下

#include <iostream>
#include <queue>
#include <vector>
using namespace std;
struct customer {
    int outtime;//第一个人结束时间
	int endtime;//最后一个人结束时间
    queue<int> q;//等待队列
};
int main() {
	int n,m,k,q;
	scanf("%d %d %d %d",&n,&m,&k,&q);
	vector<int> time(k+1), result(k+1);//顾客的服务时间及结果(用分钟存储)
	//算是第四种赋值情况
	vector<bool> sorry(k+1,0);//顾客是否不能接受服务
	vector<customer> windows(n+1);//窗口
	for(int i=1;i<=k;i++){//因为顾客从1开始标号
		scanf("%d",&time[i]);
	}

	// 因为是按照每个窗口先排一个人,都排满了再排第二个;
	// 而不是先把第一个窗口排满再排第二个窗口,故外层为m循环,内层为n循环
	int index=1;//表示当前是第几个顾客
	bool flag=0;
	for(int i=1;i<=m;i++){
		if(flag) break;
		for(int j=1;j<=n;j++){
			if(index<=k){//顾客还没全排完
				if(windows[j].endtime >= 540){//当前队列的最后一个完成后时间已经达到或超过17:00
					sorry[index]=1;
				}
				windows[j].endtime+=time[index];
				if(i==1){//每个窗口的第一个人
					windows[j].outtime = windows[j].endtime;
				}
				windows[j].q.push(time[index]);//时间入队列
				result[index]=windows[j].endtime;//当前index位顾客的结束时间
				index++;
			}
			else{
				flag=1;//直接退出
				break;
			}
		}
	}

	while(index<=k){//不在黄线内的顾客
		//搜索到最先完成一个顾客的窗口
		int w1=1;
		int mintime=windows[1].outtime;
		for(int i=2;i<=n;i++){
			if(windows[i].outtime<mintime){
				mintime=windows[i].outtime;
				w1=i;
			}
		}

		//更新队列
		if(windows[w1].endtime >= 540){
			sorry[index]=1;
		}
		windows[w1].q.pop();
		windows[w1].endtime+=time[index];
		windows[w1].outtime+=windows[w1].q.front();
		windows[w1].q.push(time[index]);
		result[index]=windows[w1].endtime;
		index++;
	}

	//开始输出
	for(int i=0;i<q;i++){
		int num;
		scanf("%d",&num);
		if(sorry[num]){
			printf("Sorry\n");
		}
		else{
			printf("%02d:%02d\n",(result[num] + 480) / 60, (result[num] + 480) % 60);
		}
	}
}
    

  • 网上的参考代码很多;
  • 以上仅是用来记录我个人的想法和答题方式;
  • 仅为入门选手,如有错误或者更好的方法欢迎指正与探讨;
  • 基本参考柳神做法;
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值