1014. Waiting in Line

4 篇文章 0 订阅
1 篇文章 0 订阅

思路: 模拟题 。题目是模拟银行多窗口队列排队,每队有上限。多余的人统一排列到外面一队。春运时,火车站进站,有点类似。处理方法:首先对每个顾客,先看看窗口队列中有无空位子,有则排到该队列中;如果没有,则看看那个窗口队列最前面那个顾客的完成时间最早,那么就可以等该顾客离去,自己加到这个队列的后面(程序中无需等待,直接加入就行了)。注意:若一个人加入某队列后,其开始是17:00以后,则显示Sorry。

练习:求最值 ,队列操作

题目描述:

Suppose a bank has N windows open for service. There is a yellow line in front of the windows which devides the waiting area into two parts. The rules for the customers to wait in line are:

  • The space inside the yellow line in front of each window is enough to contain a line with M customers. Hence when all the N lines are full, all the customers after (and including) the (NM+1)st one will have to wait in a line behind the yellow line.
  • Each customer will choose the shortest line to wait in when crossing the yellow line. If there are two or more lines with the same length, the customer will always choose the window with the smallest number.
  • Customer[i] will take T[i] minutes to have his/her transaction processed.
  • The first N customers are assumed to be served at 8:00am.

Now given the processing time of each customer, you are supposed to tell the exact time at which a customer has his/her business done.

For example, suppose that a bank has 2 windows and each window may have 2 custmers waiting inside the yellow line. There are 5 customers waiting with transactions taking 1, 2, 6, 4 and 3 minutes, respectively. At 08:00 in the morning, customer1 is served at window1 while customer2 is served at window2. Customer3 will wait in front of window1 and customer4 will wait in front of window2. Customer5 will wait behind the yellow line.

At 08:01, customer1 is done and customer5 enters the line in front of window1 since that line seems shorter now. Customer2 will leave at 08:02, customer4 at 08:06, customer3 at 08:07, and finally customer5 at 08:10.

Input

Each input file contains one test case. Each case starts with a line containing 4 positive integers: N (<=20, number of windows), M (<=10, the maximum capacity of each line inside the yellow line), K (<=1000, number of customers), and Q (<=1000, number of customer queries).

The next line contains K positive integers, which are the processing time of the K customers.

The last line contains Q positive integers, which represent the customers who are asking about the time they can have their transactions done. The customers are numbered from 1 to K.

Output

For each of the Q customers, print in one line the time at which his/her transaction is finished, in the format HH:MM where HH is in [08, 17] and MM is in [00, 59]. Note that since the bank is closed everyday after 17:00, for those customers who cannot be served before 17:00, you must output "Sorry" instead.

Sample Input
2 2 7 5
1 2 6 4 3 534 2
3 4 5 6 7
Sample Output
08:07
08:06
08:10
17:00
Sorry
参考代码:

#include <iostream>
#include <iomanip>
#include <queue>
using namespace std;
queue<int> multiqueue[20]; //
int N,M;
int leave_time[1000];
int transaction[1000];
int K;
int Q;

int main()
{
    int N,M,K,Q;
  while(cin>>N>>M>>K>>Q)
    {
    int i,j;
    for(i=0;i<N;i++)
      while(!multiqueue[i].empty())
        multiqueue[i].pop();
    for(i=0;i<K;i++)
    {
            int t;
      cin>>t;
      transaction[i]=t;
      int min=0;
      for(j=1;j<N;j++)
        if(multiqueue[min].size()>multiqueue[j].size())
          min=j;
      if(multiqueue[min].size()<M)
      {
        int time;
        if(multiqueue[min].size()==0)
          time=t;
        else
          time=t+multiqueue[min].back();
        multiqueue[min].push(time);
        leave_time[i]=time;
      }
      else
      {
        int min=0;
        for(j=1;j<N;j++)
          if(multiqueue[min].front()>multiqueue[j].front())
            min=j;
        int time=t+multiqueue[min].back();
        multiqueue[min].pop();
        multiqueue[min].push(time);
        leave_time[i]=time;
      }
    }
    for(i=1;i<=Q;i++)
    {
      int t;
      cin>>t;
      if (leave_time[t-1]-transaction[t-1]>=540)
        cout<<"Sorry"<<endl;
      else
        cout<<setw(2)<<setfill('0')<<8+leave_time[t-1]/60<<":"<<setw(2)<<setfill('0')<<leave_time[t-1]%60<<endl;
    }
    }
    return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值