POJ1861 Network MST

7 篇文章 0 订阅
该题考察,kruscal所求的生成树,最长边是尽量小的,该点与prim不同
Network

Time Limit: 1000MS

 

Memory Limit: 30000K

Total Submissions: 10476

 

Accepted: 3945

 

Special Judge

Description

Andrew is working as system administrator and is planning to establish a new network in his company. There will be N hubs in the company, they can be connected to each other using cables. Since each worker of the company must have access to the whole network, each hub must be accessible by cables from any other hub (with possibly some intermediate hubs).
Since cables of different types are available and shorter ones are cheaper, it is necessary to make such a plan of hub connection, that the maximum length of a single cable is minimal. There is another problem — not each hub can be connected to any other one because of compatibility problems and building geometry limitations. Of course, Andrew will provide you all necessary information about possible hub connections.
You are to help Andrew to find the way to connect hubs so that all above conditions are satisfied.

Input

The first line of the input contains two integer numbers: N - the number of hubs in the network (2 <= N <= 1000) and M - the number of possible hub connections (1 <= M <= 15000). All hubs are numbered from 1 to N. The following M lines contain information about possible connections - the numbers of two hubs, which can be connected and the cable length required to connect them. Length is a positive integer number that does not exceed 10 6. There will be no more than one way to connect two hubs. A hub cannot be connected to itself. There will always be at least one way to connect all hubs.

Output

Output first the maximum length of a single cable in your hub connection plan (the value you should minimize). Then output your plan: first output P - the number of cables used, then output P pairs of integer numbers - numbers of hubs connected by the corresponding cable. Separate numbers by spaces and/or line breaks.

Sample Input

4 6
1 2 1
1 3 1
1 4 2
2 3 1
3 4 1
2 4 1

Sample Output

1
4
1 2
1 3
2 3
3 4
 
#include<iostream>
#include<vector>
#include<cstdio>
#include<cstring>
#include<algorithm>
#include<queue>
#include<cmath>
#include<iomanip>
#include<complex>

using namespace std;

#define MAXN 1100

struct line
{
	int p1,p2;
	int dis;
};

line  l[MAXN*20],que[MAXN];
int n,set[MAXN],m;
int maxs,num;

bool cmp(line a,line b)
{
	return a.dis<b.dis;
}

void init(int n)
{
	for(int i=0;i<=n;i++)
		set[i]=i;
}

//查找a属于的集合编号 
int find(int a)
{
	
	int root=a;
	int temp;
	while(set[root]!=root)
		root=set[root];
	while(set[a]!=root)
	{
		temp=a;
		a=set[a];
		set[temp]=root;
	}
	return root;
}

//合并两个集合 
bool merge(int a,int b)
{
	int x=find(a);
	int y=find(b);
	if(x==y)
		return false;
	set[x]=y;
	return true;
}

void kruskal()
{ 
	for(int i=0;i<m && num<n-1;i++)
	{
		if(merge(l[i].p1,l[i].p2))
		{
			maxs=l[i].dis;
			num++;
			que[num].p1=l[i].p1;
			que[num].p2=l[i].p2;
		}
	}
}

void solve()
{
	init(n);
	for(int i=0;i<m;i++)
		scanf("%d%d%d",&l[i].p1,&l[i].p2,&l[i].dis);
	sort(l,l+m,cmp);
	maxs=0,num=0;
	kruskal();
	printf("%d\n",maxs);
	printf("%d\n",num);
	for(int i=1;i<=num;i++)
		printf("%d %d\n",que[i].p1,que[i].p2);
}

int main()
{
	while(cin>>n>>m)
		solve();
	return 0;
} 

  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值