UVA11806 Cheerleaders 容斥原理

求一个n*m的区域内,放k个棋子m,第一排,最后一排,第一列,最后一列一定要放,一共有多少种方法。

利用c(n,k)+c(n,k+1)=c(n+1,k+1)初始化所有组合。

然后将问题利用容斥原理求解即可

A第一行没人 B 最后一行没人
C第一列没人 D 最后一列没人
ans=ALL-(A)-(B)-(C)-(D)+(AB)+(AC)+(AD)+(BC)+(BD)+(CD)-(ABC)-(ACD)-(BCD)+(ABCD)

Time Limit: 2000MSMemory Limit: Unknown64bit IO Format: %lld & %llu

[Submit]   [Go Back]   [Status]  

Description

Download as PDF

C

Cheerleaders

 

In most professional sporting events, cheerleaders play a major role in entertaining the spectators. Their roles are substantial during breaks and prior to start of play. The world cup soccer is no exception. Usually the cheerleaders form a group and perform at the centre of the field. In addition to this group, some of them are placed outside the side line so they are closer to the spectators. The organizers would like to ensure that at least one cheerleader is located on each of the four sides. For this problem, we will model the playing ground as an M*N rectangular grid. The constraints for placing cheerleaders are described below:

 

§  There should be at least one cheerleader on each of the four sides. Note that, placing a cheerleader on a corner cell would cover two sides simultaneously.

§  There can be at most one cheerleader in a cell.

§  All the cheerleaders available must be assigned to a cell. That is, none of them can be left out.

 

 

The organizers would like to know, how many ways they can place the cheerleaders while maintaining the above constraints. Two placements are different, if there is at least one cell which contains a cheerleader in one of the placement but not in the other. 

 

 

 

Input

 

The first line of input contains a positive integer T<=50, which denotes the number of test cases. T lines then follow each describing one test case. Each case consists of three nonnegative integers, 2<=M, N<=20 and K<=500. Here M is the number of rows and N is the number of columns in the grid. K denotes the number of cheerleaders that must be assigned to the cells in the grid.

 

 

Output

 

For each case of input, there will be one line of output. It will first contain the case number followed by the number of ways to place the cheerleaders as described earlier. Look at the sample output for exact formatting. Note that, the numbers can be arbitrarily large. Therefore you must output the answers modulo 1000007.

 

Sample Input

Sample Output

2

2 2 1

2 3 2

Case 1: 0

Case 2: 2


#include<iostream>
#include<cstring>
#include<cstdio>
#include<string>
#include<algorithm>

using namespace std;

#define MOD 1000007
#define MAXN 550

int C[MAXN][MAXN];
int n,m,k,ans;

//c(n,k)+c(n,k+1)=c(n+1,k+1)
void init()
{
    memset(C,0,sizeof(C));
    C[0][0]=1;
    for(int i=0;i<=500;i++)
    {
        C[i][0]=C[i][i]=1;
        for(int j=1;j<i;j++)
            C[i][j]=(C[i-1][j]+C[i-1][j-1])%MOD;
    }
}

int main()
{
    int t;
    scanf("%d",&t);
    init();
    for(int J=1;J<=t;J++)
    {
        scanf("%d%d%d",&n,&m,&k);
        ans=0;
        //容斥
        //A第一行没人 B 最后一行没人
        //C第一列没人 D 最后一列没人
        //ALL-(A)-(B)-(C)-(D)+(AB)+(AC)+(AD)+(BC)+(BD)+(CD)
        //-(ABC)-(ACD)-(BCD)+(ABCD)
        for(int i=0;i<16;i++)
        {
            int b=0,r=n,c=m;
            if(i&1){r--,b++;}
            if(i&2){r--,b++;}
            if(i&4){c--,b++;}
            if(i&8){c--,b++;}
            if(b&1)
                ans=(ans+MOD-C[r*c][k])%MOD;
            else
                ans=(ans+C[r*c][k])%MOD;
        }
        printf("Case %d: %d\n",J,ans);
    }
    return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值