求只用乘法和除法最快多少步可以求到x^n
其实答案最大13,但由于树的分支极为庞大在IDDFS的同时,我们还要加2个剪枝
1 如果当前序列最大值m*2^(dep-k)<n则减去这个分支
2 如果出现两个大于n的数则要减去分支。因为里面只有一个有用,我们一定可以通过另外更加短的路径得到答案
程序看上去很慢,900ms过了
此题可以直接打表 n最大1000
Time Limit: 5000MS | Memory Limit: 65536K | |
Total Submissions: 1526 | Accepted: 787 |
Description
Starting with x and repeatedly multiplying by x, we can compute x31 with thirty multiplications:
x2 = x × x, x3 = x2 × x, x4 = x3 × x, …, x31 = x30 × x.
The operation of squaring can be appreciably shorten the sequence of multiplications. The following is a way to compute x31 with eight multiplications:
x2 = x × x, x3 = x2 × x, x6 = x3 × x3, x7 = x6 × x, x14 = x7 × x7, x15 = x14 × x, x30 = x15 × x15, x31 = x30 × x.
This is not the shortest sequence of multiplications to compute x31. There are many ways with only seven multiplications. The following is one of them:
x2 = x × x, x4 = x2 × x2, x8 = x4 × x4, x8 = x4 × x4, x10 = x8 × x2, x20 = x10 × x10, x30 = x20 × x10, x31 = x30 × x.
If division is also available, we can find a even shorter sequence of operations. It is possible to compute x31 with six operations (five multiplications and one division):
x2 = x × x, x4 = x2 × x2, x8 = x4 × x4, x16 = x8 × x8, x32 = x16 × x16, x31 = x32 ÷ x.
This is one of the most efficient ways to compute x31 if a division is as fast as a multiplication.
Your mission is to write a program to find the least number of operations to compute xn by multiplication and division starting with x for the given positive integer n. Products and quotients appearing in the sequence should be x to a positive integer’s power. In others words, x−3, for example, should never appear.
Input
The input is a sequence of one or more lines each containing a single integer n. n is positive and less than or equal to 1000. The end of the input is indicated by a zero.
Output
Your program should print the least total number of multiplications and divisions required to compute xn starting with x for the integer n. The numbers should be written each in a separate line without any superfluous characters such as leading or trailing spaces.
Sample Input
1 31 70 91 473 512 811 953 0
Sample Output
0 6 8 9 11 9 13 12
#include<iostream>
#include<cstring>
#include<algorithm>
#include<string>
#include<cstdio>
using namespace std;
int dep,n;
int a[20];
bool iddfs(int cnt,int maxs)
{
if(a[cnt]==n) return true;
if(cnt>=dep) return false;
if(maxs>n && a[cnt]>n) return false;
maxs=max(maxs,a[cnt]);
if(maxs*(1<<(dep-cnt))<n) return false;
for(int i=0;i<=cnt;i++)
{
a[cnt+1]=a[cnt]+a[i];
if(iddfs(cnt+1,maxs)) return true;
if(a[cnt]>a[i]) a[cnt+1]=a[cnt]-a[i];
else a[cnt+1]=a[i]-a[cnt];
if(iddfs(cnt+1,maxs)) return true;
}
return false;
}
int main()
{
while(~scanf("%d",&n)&&n)
{
if(n==1) printf("0\n");
else
{
a[0]=1;
for(dep=1;1;dep++)
{
if(iddfs(0,1))
{
printf("%d\n",dep);
break;
}
}
}
}
return 0;
}