Find The Multiple
Time Limit: 1000MS | Memory Limit: 10000K | |||
Total Submissions: 47745 | Accepted: 19938 | Special Judge |
Description
Given a positive integer n, write a program to find out a nonzero multiple m of n whose decimal representation contains only the digits 0 and 1. You may assume that n is not greater than 200 and there is a corresponding m containing no more than 100 decimal digits.
Input
The input file may contain multiple test cases. Each line contains a value of n (1 <= n <= 200). A line containing a zero terminates the input.
Output
For each value of n in the input print a line containing the corresponding value of m. The decimal representation of m must not contain more than 100 digits. If there are multiple solutions for a given value of n, any one of them is acceptable.
Sample Input
2
6
19
0
Sample Output
10
100100100100100100
111111111111111111
Source
题目大意:
给定一个不超过200的数,求能整除这个数并且只包含0和1的一个十进制数字。
解题思路:
用了unsigned long long直接用了DFS,暴力搜索、枚举dfs(n*10,step+1)、dfs(n*10+1,step+1),当step>19时直接跳出、因为无符号整形不超过19位,很暴力吧!!最开始我还想着用数组来存储数字呢,是我想麻烦了。
AC代码:
#include<iostream>
#include<complex>
#include<cmath>
#include<cstdio>
#include<cstring>
#include<vector>
#include<queue>
#include<stack>
#include<algorithm>
using namespace std;
#define eps 1e-9
#define inf 99999999
#define PI acos(-1)
#define MAXN 110
#define mem(a,b) memset(a,b,sizeof(a))
typedef unsigned long long ull;
bool flag;
ull n;
void dfs(int step,ull num){
if(flag)
return;
if(num%n==0){
// printf("%llu\n",num);
cout << num << endl;
flag=true;
return;
}
if(step==19) return;
dfs(step+1,num*10);
dfs(step+1,num*10+1);
}
int main(){
ios::sync_with_stdio(false);
while(cin >> n && n){
flag=false;
dfs(0,1);
}
return 0;
}