Find The Multiple-POJ-1426-BFS

Find The Multiple
Time Limit: 1000MS Memory Limit: 10000K
Total Submissions: 35763 Accepted: 14944 Special Judge

Description

Given a positive integer n, write a program to find out a nonzero multiple m of n whose decimal representation contains only the digits 0 and 1. You may assume that n is not greater than 200 and there is a corresponding m containing no more than 100 decimal digits.

Input

The input file may contain multiple test cases. Each line contains a value of n (1 <= n <= 200). A line containing a zero terminates the input.

Output

For each value of n in the input print a line containing the corresponding value of m. The decimal representation of m must not contain more than 100 digits. If there are multiple solutions for a given value of n, any one of them is acceptable.

Sample Input

2
6
19
0

Sample Output

10
100100100100100100
111111111111111111

Source

[Submit]   [Go Back]   [Status]   [Discuss]


分析:这题放在搜索,BFS暴力居然过了;

AC code:

#include <iostream>
#include <algorithm>
#include <cstdio>
#include <cstring>
#include <cmath>
#include <cstdlib>
#include <vector>
#include <queue>
#include <stack>
#include <string>
#include <map>
using namespace std;
#define LL __int64
#define INF 0x3f3f3f3f
#define eps 1
const int mod=1000000000+7;
const int maxn=1000000+50;



void bfs(int n){
    queue<LL> q;
    q.push(1);
    while(!q.empty()){
        LL s=q.front(); q.pop();
        if(s%n==0) {
            printf("%I64d\n",s );
            return;
        }
        q.push(s*10);
        q.push(s*10+1);
    }
}

int main() {
    int n;
    while(~scanf("%d",&n)&&n){
        bfs(n);
    }
    return 0;
}



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值