【计算几何】POJ 2398 Toy Storage

POJ 2398 Toy Storage 【传送门】

Toy Storage

Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 7764 Accepted: 4619

Description

Mom and dad have a problem: their child, Reza, never puts his toys away when he is finished playing with them. They gave Reza a rectangular box to put his toys in. Unfortunately, Reza is rebellious and obeys his parents by simply throwing his toys into the box. All the toys get mixed up, and it is impossible for Reza to find his favorite toys anymore. 
Reza's parents came up with the following idea. They put cardboard partitions into the box. Even if Reza keeps throwing his toys into the box, at least toys that get thrown into different partitions stay separate. The box looks like this from the top: 


We want for each positive integer t, such that there exists a partition with t toys, determine how many partitions have t, toys.

Input

The input consists of a number of cases. The first line consists of six integers n, m, x1, y1, x2, y2. The number of cardboards to form the partitions is n (0 < n <= 1000) and the number of toys is given in m (0 < m <= 1000). The coordinates of the upper-left corner and the lower-right corner of the box are (x1, y1) and (x2, y2), respectively. The following n lines each consists of two integers Ui Li, indicating that the ends of the ith cardboard is at the coordinates (Ui, y1) and (Li, y2). You may assume that the cardboards do not intersect with each other. The next m lines each consists of two integers Xi Yi specifying where the ith toy has landed in the box. You may assume that no toy will land on a cardboard. 

A line consisting of a single 0 terminates the input.

Output

For each box, first provide a header stating "Box" on a line of its own. After that, there will be one line of output per count (t > 0) of toys in a partition. The value t will be followed by a colon and a space, followed the number of partitions containing t toys. Output will be sorted in ascending order of t for each box.

Sample Input

4 10 0 10 100 0
20 20
80 80
60 60
40 40
5 10
15 10
95 10
25 10
65 10
75 10
35 10
45 10
55 10
85 10
5 6 0 10 60 0
4 3
15 30
3 1
6 8
10 10
2 1
2 8
1 5
5 5
40 10
7 9
0

Sample Output

Box
2: 5
Box
1: 4
2: 1

题目大意:与POJ 2138题目大意一致,不过输出结果变了,而且给的隔板顺序也不是默认顺序,需要重新对隔板数组进行排序。最后输出:(比如分区0有1个玩具,分区1有3个玩具,分区2有1个玩具,输出 1:2 \n 3 : 1)……原谅我不会描述。

解题思路:和POJ 2138的解题思路一模一样,不过需要对隔板数组排序,然后输出有了变化……

AC代码:

#include<iostream>
#include<complex>
#include<cmath>
#include<cstdio>
#include<cstring>
#include<vector>
#include<algorithm>
using namespace std;
#define eps 1e-9
#define inf 99999999
typedef long long ll;
struct Point{
	double x,y;
	Point(double x=0,double y=0):x(x),y(y){}
}; 
typedef Point Vector;

Vector operator + (Vector A,Vector B){return Vector(A.x+B.x,A.y+B.y);}
Vector operator - (Vector A,Vector B){return Vector(A.x-B.x,A.y-B.y);}
Vector operator * (Vector A,double p){return Vector(A.x*p,A.y*p);}
Vector operator / (Vector A,double p){return Vector(A.x/p,A.y/p);}

bool operator < (const Point& a,const Point& b)
{
	return a.x < b.x || (a.x==b.x && a.y<b.y);
}

int dcmp(double x)
{
	if(fabs(x)<eps) 
		return 0;
	else
		return x<0?-1:1;
}

bool operator == (const Point& a,const Point& b)
{
	return dcmp(a.x-b.x)==0 && dcmp(a.y-b.y)==0;
}

struct Line{
	Point v,p;
	//v up\ p down
	//Line(Point v,Point p):v(v),p(p){}
	//Point point(double t){
	//	return v+(p-v)*t;
	//}
};

//点积
double Dot(Vector A,Vector B){ return A.x*B.x+A.y*B.y;}
double Length(Vector A){return sqrt(Dot(A,A));}
double Angle(Vector A,Vector B){return acos(Dot(A,B)/Length(A)/Length(B)); }
 
//叉积
double Cross(Vector A,Vector B){return A.x*B.y-A.y*B.x;}
double Area2(Point A,Point B,Point C){return Cross(B-A,C-A);}

//向量 旋转,rad是弧度
Vector Rotate(Vector A,double rad)
{
	return Vector(A.x*cos(rad)-A.y*sin(rad),A.x*sin(rad)+A.y*cos(rad));
}
//计算单位法线
Vector Normal(Vector A)
{
	double L=Length(A);
	return Vector(-A.y/L,A.x/L);
} 

//判断折线bc是不是向ab的逆时针方向转
bool ToLeftTest(Point a,Point b,Point c)
{
	return Cross(b-a,c-b)>0;
 } 
 
//直线交点
Point GetLineIntersection(Point P,Vector v,Point Q,Vector w)
{
	Vector u=P-Q;
	//确保Cross(v,w)!=0
	double t=Cross(w,u)/Cross(v,w);
	return P+v*t; 
}

//点到直线距离
double DistanceToLine(Point P,Point A,Point B)
{
	Vector v1=B-A,v2=P-A;
	return fabs(Cross(v1,v2))/Length(v1);
	//如果不取绝对值,得到的是有向距离	
} 

//点到线段的距离
double DistanceToSegment(Point P,Point A,Point B)
{
	if(A==B) return Length(P-A);
	Vector v1=B-A,v2=P-A,v3=P-B;
	if(dcmp(Dot(v1,v2))<0)	return Length(v2);
	else if(dcmp(Dot(v1,v3))>0)	return Length(v3);
	else return fabs(Cross(v1,v2))/Length(v1);	
}  

//点在直线上的投影
Point GetLineProjection(Point P,Point A,Point B)
{
	Vector v=B-A;
	return A+v*(Dot(v,P-A)/Dot(v,v));
} 

//点是否在线段上
bool OnSegment(Point p,Point a1,Point a2)
{
	return dcmp(Cross(a1-p,a2-p))==0&&dcmp(Dot(a1-p,a2-p))<0;
 } 

//线段相交判定
bool SegmentProperIntersection(Point a1,Point a2,Point b1,Point b2){
	double c1=Cross(a2-a1,b1-a1),c2=Cross(a2-a1,b2-a1),
		   c3=Cross(b2-b1,a1-b1),c4=Cross(b2-b1,a2-b1);
	return dcmp(c1)*dcmp(c2)<0 && dcmp(c3)*dcmp(c4)<0;	
} 

//允许在线段端点相交
bool SegmentProperIntersection_duan(Point a1,Point a2,Point b1,Point b2)
{
	double c1=Cross(a2-a1,b1-a1),c2=Cross(a2-a1,b2-a1),
		   c3=Cross(b2-b1,a1-b1),c4=Cross(b2-b1,a2-b1);
	//if判断控制是否允许线段在端点处相交,根据需要添加
	if(!dcmp(c1)||!dcmp(c2)||!dcmp(c3)||!dcmp(c4))
	{
		bool f1=OnSegment(b1,a1,a2);
		bool f2=OnSegment(b2,a1,a2);
		bool f3=OnSegment(a1,b1,b2);
		bool f4=OnSegment(a2,b1,b2);
		bool f=(f1|f2|f3|f4);
		return f;	
	}	   
	return (dcmp(c1)*dcmp(c2)<0&&dcmp(c3)*dcmp(c4)<0);
} 

//多边形有向面积
//p为端点集合,n为端点个数 
double PolygonArea(Point* p,int n)
{
	double s=0;
	for(int i=0;i<n-1;i++)
		s+=Cross(p[i]-p[0],p[i+1]-p[0]);
	return s/2;
} 

//判断点在多边形内
int isPointPolygon(Point p,vector<Point> poly)
{
	int wn=0;
	int n=poly.size();
	for(int i=0;i<n;i++)
	{
		if(OnSegment(p,poly[i],poly[(i+1)%n]))
			return -1;
		int k=dcmp(Cross(poly[(i+1)%n]-poly[i],p-poly[i]));
		int d1=dcmp(poly[i].y-p.y);
		int d2=dcmp(poly[(i+1)%n].y-p.y);
		if(k>0&&d1<=0&&d2>0) wn++;
		if(k<0&&d2<=0&&d1>0) wn--;
	}	
	if(wn!=0)
		return 1;
	return 0;
} 
//-------------------------------------------------------------------------------------------------------

bool cmp(Line a,Line b)
{
	if(a.p==b.p)
		return a.v<b.v;
	return a.p<b.p;
}

#define MAXN 5005
Line L[MAXN];
int ans[MAXN];
int book[MAXN];

int main()
{
	int n,m;
	double x1,y1,x2,y2;
	while(cin >> n)
	{
		if(n==0)
			break;
		for(int i=0;i<MAXN;i++)
			ans[i]=0,book[i]=0;
		cin >> m >> x1 >> y1 >> x2 >> y2;
		Point a,b;
		a.x=x1,a.y=y2;
		b.x=x1,b.y=y1;
		L[0].p=a,L[0].v=b;		
		double up,down;
		for(int i=1;i<=n;i++)
		{
			cin >> up >> down;
			a.x=up,a.y=y1;
			b.x=down,b.y=y2;
			L[i].v=a,L[i].p=b;		
		}
		a.x=x2,a.y=y1;
		b.x=x2,b.y=y2;
		L[n+1].v=a,L[n+1].p=b;
		sort(L,L+n+1,cmp);
//		for(int i=0;i<n+2;i++)
//			cout << L[i].v.x << " " << L[i].v.y << " ",
//			cout << L[i].p.x << " " << L[i].p.y << endl;
		double x,y;
		while(m--)
		{
			cin >> x >> y;
			a.x=x,a.y=y;
			for(int i=0;i<=n+1;i++)
			{
				if(Cross(a-L[i].v,L[i].v-L[i].p)>0)
					continue;
				else
				{
					ans[i-1]++;
					break;
				}
					
			}
		}
		cout << "Box\n";
		//int book[MAXN];
		
		for(int i=0;i<n+2;i++)
		{
			book[ans[i]]++;
		}
		for(int i=1;i<n+2;i++)
			if(book[i]>0)
				cout << i << ": " <<  book[i] << endl;
		//cout << endl;
	}
	return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值