poj3468:A Simple Problem with Integers

Description:
You have N integers, A1, A2, … , AN. You need to deal with two kinds of operations. One type of operation is to add some given number to each number in a given interval. The other is to ask for the sum of numbers in a given interval.

Input
The first line contains two numbers N and Q. 1 ≤ N,Q ≤ 100000.
The second line contains N numbers, the initial values of A1, A2, … , AN. -1000000000 ≤ Ai ≤ 1000000000.
Each of the next Q lines represents an operation.
“C a b c” means adding c to each of Aa, Aa+1, … , Ab. -10000 ≤ c ≤ 10000.
“Q a b” means querying the sum of Aa, Aa+1, … , Ab.

Output
You need to answer all Q commands in order. One answer in a line.

Sample Input
10 5
1 2 3 4 5 6 7 8 9 10
Q 4 4
Q 1 10
Q 2 4
C 3 6 3
Q 2 4
Sample Output
4
55
9
15
Hint
The sums may exceed the range of 32-bit integers.

题目大意:
给定一个数组。要求能够更改给定区间的每一个数,并能查询给定区间的数的总和。

一道线段树问题,要求能进行区间修改和区间查询,使用懒惰标记法。

代码如下:

#include<iostream>
#include<algorithm>
using namespace std;
struct node
{
    long long int l,r;
    long long int n;
    long long int addMark;
}a[400000];
long long int b[100005];
int N,Q;
void init();
void build(int root,int is,int ie);
void updata(int root,int ns,int ne,int us, int ue, int addval);
long long int query(int root,int ns,int ne, int qs, int qe);
void pushDown(int root,int l);
int main()
{
    long long int i,j,x,y,z;
    char str;
    while(cin>>N>>Q)
    {
        init();
        for(i=1;i<=N;i++)
        cin>>b[i];

        build(1,1,N);

        while(Q--)
        {
            cin>>str;
            if(str=='C')
            {
                cin>>x>>y>>z;
                updata(1,1,N,x,y,z);
            }
            else
            {
                cin>>x>>y;
                cout<<query(1,1,N,x,y)<<endl;
            }
        }
    }
    return 0;
}
void init()
{
    int i,k;
    for(k=1;k<N;k<<=1)
    for(i=k;i<2*k;i++)
    {
        a[i].l=a[i].r=i-k+1;
        a[i].n=0;
        a[i].addMark=0;
    }
    for(i=k-1;i>0;i--)
    {
        a[i].l = a[2*i].l;  
        a[i].r = a[2*i+1].r;  
        a[i].n = 0; 
         a[i].addMark=0;
    }
}
void build(int root,int is,int ie)
{

    if(is==ie)
    a[root].n=b[is];

    else
    {
        int mid=(is+ie)/2;
        build(root*2,is,mid);
        build(root*2+1,mid+1,ie);
        a[root].n=a[root*2].n+a[root*2+1].n;
    }
}
void updata( int root,int ns,int ne,int us,int ue,int addval)
{
    if(us > ne || ue< ns)
         return ;
    if(us<= ns && ue>= ne)
    {
    a[root].addMark += addval;
    a[root].n += (long long int)addval*(ne-ns+1);
    return ;
    }
    pushDown(root,ne-ns+1); 
    int mid = (ns + ne) / 2;
    updata(root*2, ns, mid, us, ue, addval);
    updata(root*2+1, mid+1, ne, us, ue, addval);
    a[root].n =a[root*2].n+a[root*2+1].n;
}
long long int query(int root,int ns,int ne,int qs,int qe)
{
    if(qs > ne || qe< ns)
         return 0;
  if(qs <= ns && qe >= ne)
        return a[root].n;

        pushDown(root,ne-ns+1);

    int mid = (ns + ne) / 2;

   return query(root*2, ns, mid, qs, qe)+query(root*2+1, mid + 1, ne, qs, qe);
}
void pushDown( int root,int l)
{
    if(a[root].addMark!=0)
    {
        a[root*2].addMark+=a[root].addMark;
        a[root*2+1].addMark+=a[root].addMark;

        a[root*2].n+=a[root].addMark*(l-(l>>1));
        a[root*2+1].n+=a[root].addMark*(l>>1);
        a[root].addMark=0;
    }
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值