寒假训练01C:hdu1069

Problem Description
A group of researchers are designing an experiment to test the IQ of a monkey. They will hang a banana at the roof of a building, and at the mean time, provide the monkey with some blocks. If the monkey is clever enough, it shall be able to reach the banana by placing one block on the top another to build a tower and climb up to get its favorite food.

The researchers have n types of blocks, and an unlimited supply of blocks of each type. Each type-i block was a rectangular solid with linear dimensions (xi, yi, zi). A block could be reoriented so that any two of its three dimensions determined the dimensions of the base and the other dimension was the height.

They want to make sure that the tallest tower possible by stacking blocks can reach the roof. The problem is that, in building a tower, one block could only be placed on top of another block as long as the two base dimensions of the upper block were both strictly smaller than the corresponding base dimensions of the lower block because there has to be some space for the monkey to step on. This meant, for example, that blocks oriented to have equal-sized bases couldn’t be stacked.

Your job is to write a program that determines the height of the tallest tower the monkey can build with a given set of blocks.

Input
The input file will contain one or more test cases. The first line of each test case contains an integer n,
representing the number of different blocks in the following data set. The maximum value for n is 30.
Each of the next n lines contains three integers representing the values xi, yi and zi.
Input is terminated by a value of zero (0) for n.

Output
For each test case, print one line containing the case number (they are numbered sequentially starting from 1) and the height of the tallest possible tower in the format “Case case: maximum height = height”.

Sample Input
1
10 20 30
2
6 8 10
5 5 5
7
1 1 1
2 2 2
3 3 3
4 4 4
5 5 5
6 6 6
7 7 7
5
31 41 59
26 53 58
97 93 23
84 62 64
33 83 27
0

Sample Output
Case 1: maximum height = 40
Case 2: maximum height = 21
Case 3: maximum height = 28
Case 4: maximum height = 342

题目大意
给你n种类型的长方块,求这些长方块最高能摞多高(每种长方块的数量无限制),要求在上面的长方块长与宽必须严格小于下方的长方块。

解题思路
这道题是一个dp问题,变形的求最大递减子序列和。因为给的数据并未确定哪个做高,又因为长方块是无限供应的,所以我们可以把不同的数据做高的三种情况都存进去。又因为在上面的长方块的面积不可能大于在下面的,所以可以根据面积按从大到小的顺序排序,以保证以第i个长方块为最后一个元素的子序列的前面元素只能在0–i-1中找。最后对处理后的输出dp后求出的最大值即为所求。

代码

#include<iostream>
#include<memory.h>
#include<algorithm>
using namespace std;
class block
{
    public:
    int l;
    int w;
    int h;
    int area;
};
bool cmp(const block &a,const block &b)
{
    return a.area>b.area;
}
int dp[100];
int main()
{
    int n;

    block temp;
    int i,j;
    int x,y,z;
    int cnt=1;
    while(cin>>n&&n!=0)
    {
        memset(dp,0,sizeof(dp));
            block a[100];
            i=1;
            for(j=0;j<n;j++)
            {
                cin>>x>>y>>z;
                 temp.l=x;
                  temp.w=y;
                     temp.area=x*y;
                   temp.h=z;
                  a[i++]=temp;

                 temp.l=z;
                     temp.w=y;
                        temp.area=z*y;
                      temp.h=x;
                   a[i++]=temp;

                 temp.l=x;
                     temp.w=z;
                  temp.area=x*z;
                  temp.h=y;
                    a[i++]=temp;
            }
            sort(a+1,a+3*n+1,cmp);

            for(i=1;i<=3*n;i++)
            {
                dp[i]=a[i].h;
            for(j=1;j<i;j++)
            {
                if(a[i].l<a[j].l&&a[i].w<a[j].w||a[i].l<a[j].w&&a[i].w<a[j].l)
                dp[i]=max(dp[i],dp[j]+a[i].h);

            }
            }
            sort(dp+1,dp+1+3*n);
            cout<<"Case "<<cnt++<<": maximum height = "<<dp[3*n]<<endl;


    }
    return 0;
}
  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值