1049 Counting Ones (30 分)

1049 Counting Ones (30 分)

The task is simple: given any positive integer N, you are supposed to count the total number of 1's in the decimal form of the integers from 1 to N. For example, given N being 12, there are five 1's in 1, 10, 11, and 12.

Input Specification:

Each input file contains one test case which gives the positive N (≤2​30​​).

Output Specification:

For each test case, print the number of 1's in one line.

Sample Input:

12

Sample Output:

5

 题目中要求所有小于等于n的数字送出现1的次数,n为12时出现1的数字为1,10,11,12,出现1的次数为5

解题思想和数位DP十分类似,只是这个较为简单

依次枚举每个数位上出现的数字,假如数字为106523

数位左边数字(left)右边数字(right)当前数位为1的数量
个位31065230106523*pow(10,0)
十位2106523(10652+1)*pow(10,1)
百位510623(106+1)*pow(10,2)
千位610523(10+1)*pow(10,3)
万位0165231*pow(10,4)
十万位1006523

0*pow(10,5) + 6523

 当前数位位于[2,9]时,此时当前数位为1的数字数量为:(left+1)*pow(10,数位右边数字数量)                   left+1因为其那面的数字范围为[0,left]

当前数位为1是,此时左边只能取[0,left),当左边取left时,当前数位为1,包含的数量为right的大小

当前数位为0时,左边左边只能取[0,left),当左边取left时,那么此前数位无论如何都不能为1,所以只包含前一部分

#include <iostream>
#include <algorithm>
#include <cstdio>
#include <cstring>
#include <stack>
#include <queue>
#include <cmath>
#define ll long long
#define INF 0x3f3f3f3f

using namespace std;
int n;

int main()
{
    scanf("%d",&n);
    int tmp = 1,x = n;
    int now,left,right;
    ll ans = 0;

    while(x)
    {
        now = x %10;
        right = n % tmp;
        tmp *= 10;
        left = n / tmp;
        x /= 10;
        if(now == 0)
            ans +=  left * (tmp / 10);
        else if(now == 1)
            ans += left * (tmp / 10) + right +1;
        else
            ans += (left+1) * (tmp / 10);
    }
    cout << ans <<endl;

}

参考博客

https://blog.csdn.net/Dream_Weave/article/details/81737825

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
题目简述: 给定一个整数n,你需要求出1到n这n个整数的二进制(binary)表示中数字1出现的次数。例如,对于n=3,1到3这3个整数的二进制表示别是:1, 10, 11,其中1出现的次数为2次。因此,输出2即可。 题目思路: 这道题可以用暴力求解法:枚举1到n的每个整数,然后统计对应的二进制表示中1的个数即可。但此种做法不适用于大数据。因此,我们需要寻找更为高效的算法。其中一种常见方法是用每一位的数字来计算。 例如,对于一个二进制数11010,我们可以从低到高,第一位统计在0~1范围内出现的次数,第二位统计在0~3范围内出现的次数,第三位在0~7范围内,第四位在0~15范围内,最后统计总体中的1的个数。因为,我们可以发现,对于n的第i位上的数字,它出现1的次数由(n / (i*10) * i)个1,除去i-1位之后,如果大于2,则还要加上i个1。再来看一个具体的例子,对于11010,第一位上有10种情况,0出现5次,1也出现5次,对于第二位,共有110, 101, 100, 011, 010, 001, 000七种情况,其中从00到01这两种情况中,每个数字都出现了两次1,因此一共出现了2*2=4次1。同样地,对于 101 和 011 这两种情况,也是如此。 因此,最终代码如下(基于C++): #include <iostream> using namespace std; #define int long long//避免溢出 signed main(){ int n, ans; cin >> n; for(int l = 1, r; l <= n; l = r + 1){ int k = n / l; r = n / k; ans += (r - l + 1) * (k / 10); int t = (k % 10) * l; if(t >= l) ans += t - l + 1; } cout << ans << endl; return 0; } 注意:本题的数据范围比较大,因此需要使用int long long类型避免溢出。

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值