1049 Counting Ones (30 分) PAT 甲级 数1的个数

1049 Counting Ones (30 分)

The task is simple: given any positive integer N, you are supposed to count the total number of 1's in the decimal form of the integers from 1 to N. For example, given N being 12, there are five 1's in 1, 10, 11, and 12.

Input Specification:

Each input file contains one test case which gives the positive N (≤2​30​​).

Output Specification:

For each test case, print the number of 1's in one line.

Sample Input:

12

Sample Output:

5

这道题,我第一次也想到了逐位分析,但是分析方向错了

分为三种情况:

如果当前位:(left 表示当前位置左边的数值,right表示当前位置右边的数值)

==0:  left*right的位数

>1:  (left+1)*right的位数

==1 :left*right的位数+right+1

#include<iostream>
using namespace std;
int main()
{
	int n,i,j,l=0,r=1,cur=0,sum=0;
	scanf("%d",&n);
	l=n;
	while(l!=0)
	{
		cur=l%10;
		l/=10;
		
//		printf("%d\n",sum);
		if(cur==0)
		{
			sum+=l*r;
//			printf("1   %d\n",l*r);
		}
		
		else
		if(cur==1)
		{
			sum+=l*r+n%r+1;
//			printf("2   %d\n",l*r+n%r+1);
		}
		else
		{
			sum+=(l+1)*r;
//			printf("3   %d\n",(l+1)*r);
		}
		r*=10;
	}
	printf("%d\n",sum);
	return 0;
}

 

 

 

 

 

 

 

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值