PAT甲级1020. Tree Traversals (25)

Suppose that all the keys in a binary tree are distinct positive integers. Given the postorder and inorder traversal sequences, you are supposed to output the level order traversal sequence of the corresponding binary tree.
Input Specification:
Each input file contains one test case. For each case, the first line gives a positive integer N (<=30), the total number of nodes in the binary tree. The second line gives the postorder sequence and the third line gives the inorder sequence. All the numbers in a line are separated by a space.
Output Specification:
For each test case, print in one line the level order traversal sequence of the corresponding binary tree. All the numbers in a line must be separated by exactly one space, and there must be no extra space at the end of the line.
Sample Input:
7
2 3 1 5 7 6 4
1 2 3 4 5 6 7
Sample Output:
4 1 6 3 5 7 2

给出二叉树的后序遍历和中序遍历,重建二叉树;然后再进行层次遍历。

#include <cstdio>
using namespace std;
#include <vector>
#include <queue>

vector<int> postorder;
vector<int> inorder;

struct node {
  int value;
  node* left;
  node* right;
  node() {
    value = 0;
    left = NULL;
    right = NULL;
  }
};

/*把inorder[L1...R1]和postorder[L2...R2]建成一棵二叉树,返回树根*/
node* buildTree(int L1,int R1,int L2,int R2) {
  if(L1>R1) return NULL; 
  node* root = new node();
  root->value = postorder[R2];
  int j = L1;
  while(inorder[j]!=root->value) j++;
  int cnt=j-L1;//左子树的结点个数
  root->left=buildTree(L1,j-1,L2,L2+cnt-1);
  root->right=buildTree(j+1,R1,L2+cnt,R2-1); 
  return root;
}

int main() {
  int N;
  scanf("%d", &N);

  postorder.resize(N);
  inorder.resize(N);
  for (int i = 0; i<N; i++) scanf("%d", &postorder[i]);
  for (int i = 0; i<N; i++) scanf("%d", &inorder[i]);

  node* root=buildTree(0,N-1,0,N-1);

  queue<node*> Q;
  Q.push(root);
  printf("%d", root->value);
  while (!Q.empty()) {
    node* tmp = Q.front();
    if(tmp->value!=root->value) printf(" %d", tmp->value);
    if (tmp->left != NULL) Q.push(tmp->left);
    if (tmp->right != NULL) Q.push(tmp->right);
    Q.pop();
  }

  return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值