PAT甲级1059. Prime Factors (25)

Given any positive integer N, you are supposed to find all of its prime factors, and write them in the format N = p1 ^ k1 * p2 ^ k2 * …* pm ^ km .
Input Specification:
Each input file contains one test case which gives a positive integer N in the range of long int.
Output Specification:
Factor N in the format N = p1 ^ k1 * p2 ^ k2 * …* pm ^ km , where pi ’s are prime factors of N in increasing order, and the exponent ki is the number of pi – hence when there is only one pi , ki is 1 and must NOT be printed out.
Sample Input:
97532468
Sample Output:
97532468=2^2*11*17*101*1291

#include <vector>
#include <iostream>
#include <cmath>
using namespace std;

bool isPrime(long int N){
    if(N==1) return false;
    if(N==2) return true;

    int r=floor(sqrt(N)+0.5);
    for(long int i=2;i<=r;i++) {
        if(N%i==0) return false;
    }
    return true;
}

struct PF{
    long int prime;
    long int expo;
    PF(long int x,long int y):prime(x),expo(y){}
};

vector<PF> getPF(long int N){
    vector<PF> result;

    int count=0;
    long int num=N;

    for(int i=2;i<=N;i++){
        if(num<=1) break;//没有这句会超时 
        int j=0;
        int flag=1;
        if(isPrime(i)) {
            count=0;
            while(num%i==0){
                num/=i;
                count++;
            }
            if(count>0) {
                result.push_back(PF(i,count));
            }
        }
    }
    return result;
}

int main(){
    long int N;
    cin>>N;

    if(N==1) {
        cout<<"1=1"<<endl;
        return 0;
    }

    vector<PF> result=getPF(N);

    int sz=result.size();
    cout<<N<<"=";
    if(result[0].expo>1) cout<<result[0].prime<<"^"<<result[0].expo;
    else cout<<result[0].prime;
    for(long int k=1;k<sz;k++){
        if(result[k].expo>1) cout<<"*"<<result[k].prime<<"^"<<result[k].expo;
        else cout<<"*"<<result[k].prime;
    }

    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值