The Number Off of FFF

The Number Off of FFF

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 0    Accepted Submission(s): 0


Problem Description
  
  
X soldiers from the famous " *FFF* army" is standing in a line, from left to right. You, as the captain of *FFF*, decides to have a "number off", that is, each soldier, from left to right, calls out a number. The first soldier should call "One", each other soldier should call the number next to the number called out by the soldier on his left side. If every soldier has done it right, they will call out the numbers from 1 to X, one by one, from left to right. Now we have a continuous part from the original line. There are N soldiers in the part. So in another word, we have the soldiers whose id are between A and A+N-1 (1 <= A <= A+N-1 <= X). However, we don't know the exactly value of A, but we are sure the soldiers stands continuously in the original line, from left to right. We are sure among those N soldiers, exactly one soldier has made a mistake. Your task is to find that soldier.
 

Input
  
  
The rst line has a number T (T <= 10) , indicating the number of test cases. For each test case there are two lines. First line has the number N, and the second line has N numbers, as described above. (3 <= N <= 10 5) It guaranteed that there is exactly one soldier who has made the mistake.
 

Output
  
  
For test case X, output in the form of "Case #X: L", L here means the position of soldier among the N soldiers counted from left to right based on 1.
 

Sample Input
  
  
2 3 1 2 4 3 1001 1002 1004
 

Sample Output
  
  
Case #1: 3 Case #2: 3
 

Source
  
  
2013 ACM/ICPC Asia Regional Online —— Warmup2
 

简单判断,注意第一个报错的情况。
#include <iostream>

using namespace std;

void input()
{
    int t, n, k = 0;
    cin >> t;
    
    while (t--)
    {
        cin >> n;
        int results = 1;
        long long a, b;
        
        cin >> b;
        for (int i = 2; i <= n; i++)
        {
            cin >> a;
            if (a != b + 1)
            {
                results = i;    
            }
            b = a;
        }
        
        cout << "Case #" << ++k << ": ";
        cout << results << endl;
    }
}

int main()
{
    std::ios::sync_with_stdio(false);
    input();
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值