周赛一 HDU 4727

Description

X soldiers from the famous "   *FFF*  army" is standing in a line, from left to right.  
You, as the captain of   *FFF*, decides to have a "number off", that is, each soldier, from left to right, calls out a number. The first soldier should call "One", each other soldier should call the number next to the number called out by the soldier on his left side. If every soldier has done it right, they will call out the numbers from 1 to X, one by one, from left to right.  
Now we have a continuous part from the original line. There are N soldiers in the part. So in another word, we have the soldiers whose id are between A and A+N-1 (1 <= A <= A+N-1 <= X). However, we don't know the exactly value of A, but we are sure the soldiers stands continuously in the original line, from left to right.  
We are sure among those N soldiers, exactly one soldier has made a mistake. Your task is to find that soldier.
 

Input

The rst line has a number T (T <= 10) , indicating the number of test cases.  
For each test case there are two lines. First line has the number N, and the second line has N numbers, as described above. (3 <= N <= 10   5)  
It guaranteed that there is exactly one soldier who has made the mistake.
 

Output

For test case X, output in the form of "Case #X: L", L here means the position of soldier among the N soldiers counted from left to right based on 1.
 

Sample Input

       
       
2 3 1 2 4 3 1001 1002 1004
 

Sample Output

       
       
Case #1: 3 Case #2: 3

给出N个连续的数字(3<=N<=10^5),这N个数本来应该是连续的N个数,比如1,2,3,4,5或者2007,2008,2009等,但是其中有一个数错了,比如2007,2010,2009 则这三个数中错误的那个数就是2010了,现在要你找出错误的那个数的编号。(编号从1开始)

如果队列中一个数错误了,接下来的所有数也会接着错下去(即在错误的那个数X的基础上开始 X+1,X+2,X+3等)而不是说接下来的数还是Y Y+1 等.如队列 1,2,3,4,5,6,7,8 中错的数是 1

#include<iostream>
#include<cstdio>

using namespace std;

int a[1000010];
int main()
{
	int T;
	while(cin>>T)
	{
		for(int k=1;k<=T;k++)
		{
			int n;
			cin>>n;
			for(int i=0;i<n;i++)
			{
				cin>>a[i];
			}
			int flag=0;
			for(int i=0;i<n;i++)
				if(a[i]!=a[0]+i)
			{
				printf("Case #%d: %d",k,i+1);
				flag=0;
				break;
			}
			else
			    flag=1;

			if(flag==1)
				printf("Case #%d: 1",k);
            cout<<endl;
		}
	}
}
//此题坑点当序号全部连续时就说明1错了
//还有就是n可能存在小于3的情况





  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值